Excel подсчет количества ячеек с определенным значением

Алан-э-Дейл       04.09.2022 г.

Оглавление

Функция СЧЕТЕСЛИ в Excel и примеры ее использования

Функция СЧЕТЕСЛИ входит в группу статистических функций. Позволяет найти число ячеек по определенному критерию. Работает с числовыми и текстовыми значениями, датами.

Синтаксис и особенности функции

Сначала рассмотрим аргументы функции:

  • Диапазон – группа значений для анализа и подсчета (обязательный).
  • Критерий – условие, по которому нужно подсчитать ячейки (обязательный).

В диапазоне ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

В качестве критерия может быть ссылка, число, текстовая строка, выражение. Функция СЧЕТЕСЛИ работает только с одним условием (по умолчанию). Но можно ее «заставить» проанализировать 2 критерия одновременно.

Рекомендации для правильной работы функции:

  • Если функция СЧЕТЕСЛИ ссылается на диапазон в другой книге, то необходимо, чтобы эта книга была открыта.
  • Аргумент «Критерий» нужно заключать в кавычки (кроме ссылок).
  • Функция не учитывает регистр текстовых значений.
  • При формулировании условия подсчета можно использовать подстановочные знаки. «?» — любой символ. «*» — любая последовательность символов. Чтобы формула искала непосредственно эти знаки, ставим перед ними знак тильды (~).
  • Для нормального функционирования формулы в ячейках с текстовыми значениями не должно пробелов или непечатаемых знаков.

Функция СЧЕТЕСЛИ в Excel: примеры

Посчитаем числовые значения в одном диапазоне. Условие подсчета – один критерий.

У нас есть такая таблица:

Посчитаем количество ячеек с числами больше 100. Формула: =СЧЁТЕСЛИ(B1:B11;»>100″). Диапазон – В1:В11. Критерий подсчета – «>100». Результат:

Если условие подсчета внести в отдельную ячейку, можно в качестве критерия использовать ссылку:

Посчитаем текстовые значения в одном диапазоне. Условие поиска – один критерий.

Формула: =СЧЁТЕСЛИ(A1:A11;»табуреты»). Или:

Во втором случае в качестве критерия использовали ссылку на ячейку.

Формула с применением знака подстановки: =СЧЁТЕСЛИ(A1:A11;»таб*»).

Для расчета количества значений, оканчивающихся на «и», в которых содержится любое число знаков: =СЧЁТЕСЛИ(A1:A11;»*и»). Получаем:

Формула посчитала «кровати» и «банкетки».

Используем в функции СЧЕТЕСЛИ условие поиска «не равно».

Формула: =СЧЁТЕСЛИ(A1:A11;»»&»стулья»). Оператор «» означает «не равно». Знак амперсанда (&) объединяет данный оператор и значение «стулья».

При применении ссылки формула будет выглядеть так:

Часто требуется выполнять функцию СЧЕТЕСЛИ в Excel по двум критериям. Таким способом можно существенно расширить ее возможности. Рассмотрим специальные случаи применения СЧЕТЕСЛИ в Excel и примеры с двумя условиями.

  1. Посчитаем, сколько ячеек содержат текст «столы» и «стулья». Формула: =СЧЁТЕСЛИ(A1:A11;»столы»)+СЧЁТЕСЛИ(A1:A11;»стулья»). Для указания нескольких условий используется несколько выражений СЧЕТЕСЛИ. Они объединены между собой оператором «+».
  2. Условия – ссылки на ячейки. Формула: =СЧЁТЕСЛИ(A1:A11;A1)+СЧЁТЕСЛИ(A1:A11;A2). Текст «столы» функция ищет в ячейке А1. Текст «стулья» — на базе критерия в ячейке А2.
  3. Посчитаем число ячеек в диапазоне В1:В11 со значением большим или равным 100 и меньшим или равным 200. Формула: =СЧЁТЕСЛИ(B1:B11;»>=100″)-СЧЁТЕСЛИ(B1:B11;»>200″).
  4. Применим в формуле СЧЕТЕСЛИ несколько диапазонов. Это возможно, если диапазоны являются смежными. Формула: =СЧЁТЕСЛИ(A1:B11;»>=100″)-СЧЁТЕСЛИ(A1:B11;»>200″). Ищет значения по двум критериям сразу в двух столбцах. Если диапазоны несмежные, то применяется функция СЧЕТЕСЛИМН.
  5. Когда в качестве критерия указывается ссылка на диапазон ячеек с условиями, функция возвращает массив. Для ввода формулы нужно выделить такое количество ячеек, как в диапазоне с критериями. После введения аргументов нажать одновременно сочетание клавиш Shift + Ctrl + Enter. Excel распознает формулу массива.

СЧЕТЕСЛИ с двумя условиями в Excel очень часто используется для автоматизированной и эффективной работы с данными. Поэтому продвинутому пользователю настоятельно рекомендуется внимательно изучить все приведенные выше примеры.

ПРОМЕЖУТОЧНЫЕ.ИТОГИ и СЧЕТЕСЛИ

Посчитаем количество реализованных товаров по группам.

  1. Сначала отсортируем таблицу так, чтобы одинаковые значения оказались рядом.
  2. Первый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ» — «Номер функции». Это числа от 1 до 11, указывающие статистическую функцию для расчета промежуточного результата. Подсчет количества ячеек осуществляется под цифрой «2» (функция «СЧЕТ»).

Скачать примеры функции СЧЕТЕСЛИ в Excel

Формула нашла количество значений для группы «Стулья». При большом числе строк (больше тысячи) подобное сочетание функций может оказаться полезным.

Как посчитать сумму (формулы СУММ и СУММЕСЛИМН)

Можно, конечно, составлять формулы в ручном режиме, печатая «=A1+B1+C1» и т.п. Но в Excel есть более быстрые и удобные инструменты.

Один из самых простых способов сложить все выделенные ячейки — это использовать опцию автосуммы (Excel сам напишет формулу и вставить ее в ячейку).

Что нужно сделать, чтобы посчитать сумму определенных ячеек:

  1. сначала выделяем ячейки (см. скрин ниже);
  2. далее открываем раздел «Формулы» ;
  3. следующий шаг жмем кнопку «Автосумма» . Под выделенными вами ячейками появиться результат из сложения;
  4. если выделить ячейку с результатом (в моем случае — это ячейка E8) — то вы увидите формулу «=СУММ(E2:E7)» .
  5. таким образом, написав формулу «=СУММ(xx)» , где вместо xx поставить (или выделить) любые ячейки, можно считать самые разнообразные диапазоны ячеек, столбцов, строк.

Автосумма выделенных ячеек

Как посчитать сумму с каким-нибудь условием

Довольно часто при работе требуется не просто сумма всего столбца, а сумма определенных строк (т.е. выборочно). Предположим простую задачу: нужно получить сумму прибыли от какого-нибудь рабочего (утрировано, конечно, но пример более чем реальный).

Я в своей таблицы буду использовать всего 7 строк (для наглядности), реальная же таблица может быть намного больше. Предположим, нам нужно посчитать всю прибыль, которую сделал «Саша». Как будет выглядеть формула:

» =СУММЕСЛИМН( F2:F7 ; A2:A7 ;»Саша») » — ( прим .: обратите внимание на кавычки для условия — они должны быть как на скрине ниже, а не как у меня сейчас написано на блоге). Так же обратите внимание, что Excel при вбивании начала формулы (к примеру «СУММ

«), сам подсказывает и подставляет возможные варианты — а формул в Excel’e сотни!;
F2:F7 — это диапазон, по которому будут складываться (суммироваться) числа из ячеек;
A2:A7 — это столбик, по которому будет проверяться наше условие;
«Саша» — это условие, те строки, в которых в столбце A будет «Саша» будут сложены (обратите внимание на показательный скриншот ниже).

Сумма с условием

Примечание : условий может быть несколько и проверять их можно по разным столбцам.

Подсчет числовых значений с одним критерием

Данные будем брать из диапазона A15:A25 (см. файл примера ).

Критерий

Формула

Результат

Примечание

>=10

= СЧЁТЕСЛИ($A$2:$A$12; “>=10”)

4

Подсчитывает количество ячеек, содержащих числа равных или более 10. Критерий указан в формуле

= СЧЁТЕСЛИ( $A$2:$A$12;C3)

8

Подсчитывает количество ячеек, содержащих числа равных или меньших 10. Критерий указан через ссылку

>= (ячейка С4)11(ячейка С5)

= СЧЁТЕСЛИ($A$2:$A$12; C4&C5)

3

Подсчитывает количество ячеек, содержащих числа равных или более 11. Критерий указан через ссылку и параметр

Примечание . О подсчете значений, удовлетворяющих нескольким критериям читайте в статье Подсчет значений со множественными критериями . О подсчете чисел с более чем 15 значащих цифр читайте статью Подсчет ТЕКСТовых значений с единственным критерием в MS EXCEL .

Формула суммы в Excel

Чтобы сложить несколько чисел, которые находятся в разных местах, с помощью формулы, воспользуйтесь следующим способом:

  1. Откройте ту таблицу, в которой нужно произвести расчет.
  2. В свободной ячейке поставьте курсор и введите знак «=» без кавычек. Программа автоматически активирует функцию, предназначенную для суммирования чисел в ячейках таблицы.
  3. Щелкните левой кнопкой мыши по той ячейке, данные которой будут применены в расчете. Там, где поставлен знак «=», появится значение из цифр и букв, обозначающее местоположение числа в таблице. При этом буква – это столбец, а цифра – строка.
  4. Напечатайте в поле со знаком «=» после адреса ячейки (B3 в примере) «+», затем выберите ячейку для подсчета, кликнув по ней. Проделывайте это с каждым полем, данные которого требуются для сложения.

Чтобы найти сумму чисел в выбранных ячейках, нажмите на клавишу Enter. В поле, где складывались значения расположения данных, появится число – сумма данных.

При пустом значении ячейки или текста в ней программа автоматически проигнорирует данные. В верхней строке возможно вводить формулу вручную после знака «=»

Буквенно-цифровое значение ячейки необходимо складывать с помощью «+», при этом неважно, верхний или нижний регистр используется. Для получения результата также нажмите на клавишу ввода

Подсчет ячеек в Excel, используя функции СЧЕТ и СЧЕТЕСЛИ

СЧЕТ()

​ могут не быть​​Обозначаем ячейку, в которую​​Запускается окно аргументов. Аргументы​ отличается от предыдущего​ тайны функций​СЧЕТЕСЛИ​ в Excel требуется​:​ работы с данными.​ поиска – один​Примечания:​

​СУММЕСЛИМН​Другими словами нужно ввести​ полем​ версиях Excel для​​+SHIFT+ВВОД.​​ 7 и 6,​

​ численными: например, некоторые​ будет выводиться результат​ те же самые,​

​ способа тем, что​​СЧЕТ​​позволяет подсчитывать ячейки,​ подсчитать количество ячеек​AleksSid​

​ Поэтому продвинутому пользователю​ критерий.​ ​в автозавершении формулы,​​ формулу для суммирования​​Сумма_продаж_2​ Mac с помощью​Чтобы эти примеры формул​ то число 6​ участники могли ввести​ и запускаем Мастер​

​ что и при​ позволяет зафиксировать подсчет​и​ содержащие текстовые значения.​ на рабочем листе.​​, Проблема просто в​​ настоятельно рекомендуется внимательно​

СЧЕТЕСЛИ()

​Формула: =СЧЁТЕСЛИ(A1:A11;»табуреты»). Или:​​Дополнительные примеры можно найти​​ откроется статья, справкой.​ чисел в столбце,​и выберите пункт​+ Shift + Ввод.​ работали, вторым аргументом​ встречается два раза.​ значения-заполнители, такие как​ функций. В нем​

​ использовании предыдущего способа.​ определенного диапазона в​СЧЕТЕСЛИ​ Например, следующая формула​

​ Это могут быть​​ том, что неизвестно​ изучить все приведенные​Во втором случае в​ в статьеФункция СУММЕСЛИМН.​Если вы хотите поэкспериментировать​ если они удовлетворяют​Параметры поля значений​

​Сводную таблицу можно использовать​​ функции ЕСЛИ должно​​Если столбец содержит «Грачев»,​ «TBD». Для выполнения​​ ищем элемент​​ В их роли​​ отдельной ячейке. То​​, а также их​ возвращает количество ячеек​ пустые или заполненные​ конечное количество строк​ выше примеры.​

​ качестве критерия использовали​Если вы хотите подсчитать​ с функцией СУММЕСЛИМН,​ условиям. Что диапазон​​.​​ для отображения итогов​ быть число.​ «Туманов», «Туманов» и​

​ такой задачи можно​«СЧЁТЕСЛИМН»​ выступают ссылки на​ есть, для просмотра​ ближайших соратников –​

​ со словом «текст»,​​ ячейки, содержащие только​​ для диапазона. Я​Посчитаем количество реализованных товаров​ ссылку на ячейку.​ итоговое значение только​ то некоторые образцы​ ячеек — это​В диалоговом окне​ и подсчет количества​

​Дополнительные сведения об этих​ «Туманов», «Туманов» встречается​ использовать функцию СЧЁТЗ.​. Выделяем его и​​ ячейки. Вставляем координаты​​ информации по нему​СЧЕТЗ​ причем регистр не​ числовые значения, а​ реализую опрос на​

​ по группам.​Формула с применением знака​ для одного диапазона​ данных и формулы,​

​ первый​​Параметры поля значений​​ уникальных значений. Сводная​ функциях см. в​​ три раза.​​Пример.​ жмем на кнопку​ диапазонов на листе,​​ область не нужно​​,​ имеет значения.​​ в некоторых случаях,​​ гугл-форме, результаты которого​Сначала отсортируем таблицу так,​ подстановки: =СЧЁТЕСЛИ(A1:A11;»таб*»).​ с учетом значения​​ использующей функцию.​​аргумент​​выполните указанные ниже​​ таблица образом интерактивных​

​ статьях Функция СЧЁТ​Подсчитать количество вхождений значения​Эта функция подсчитывает только​«OK»​ в которых нужно​ будет постоянно выделять.​СЧИТАТЬПУСТОТЫ​Логическое условие функции​​ их содержимое должно​​ заносятся в данную​​ чтобы одинаковые значения​​Для расчета количества значений,​ в другом диапазоне,​​Вы можете работать с​​в этой формуле​​ действия.​​ можно вычислять итоговые​​ и Функция ЕСЛИ.​​ можно несколькими способами.​ ячейки с данными,​.​ подсчитать количество заполненных​

​Выделяем область, в которую​

office-guru.ru>

Синтаксис функции СЧЁТ

Функция принимает один или более аргументов, каждый из которых может быть диапазоном ячеек или адресом отдельной ячейки. Также можно использовать переменные, заданные с помощью Диспетчера имён, если переменная соответствует диапазону или адресу отдельной ячейки.

Чаще всего в качестве аргументов указывают один или более диапазонов ячеек. Два и более диапазона может потребоваться указать в тех случаях, когда неудобно указать один диапазон (таблицу). Например, если между таблицами ваших данных находятся ячейки (или другие таблицы), подсчитывать «числовые» ячейки в которых не требуется.

Обобщённый синтаксис функции СЧЁТ выглядит следующим образом:СЧЁТ(значение1; ; …)

Всего функция может принимать до 255-ти аргументов, причём первый является обязательным. Аргументы разделяются точкой с запятой.

По каким-то причинам во встроенной справке Excel при указании синтаксиса всех функций в качестве разделителя аргументов используется запятая. Однако нужно использовать именно точку с запятой.

Если Вы не хотите писать формулу вручную, воспользуйтесь Мастером функций Excel. Однако синтаксис функции СЧЁТ всё же необходимо помнить, если Вы используете её внутри составных формул.

Как можно использовать сводную таблицу.

Вот обычная задача, которую все пользователи Excel должны время от времени выполнять. У вас есть список данных (к примеру, названий товаров), и нужно узнать количество уникальных позиций в этом списке. Как это сделать? Проще, чем вы думаете 🙂

В версиях Excel выше 2013  есть специальная функция, которая позволяет автоматически пересчитывать различные значения в сводной таблице. На следующем рисунке показано, как выглядит этот счетчик:

Чтобы создать сводную таблицу со счетчиком для определенного столбца, выполните следующие действия.

  1. Выберите данные для включения в сводную таблицу, перейдите на вкладку «Вставка» и нажмите кнопку «Сводная таблица» .
  2. В диалоговом окне «Создание сводной таблицы» выберите, следует ли разместить сводную таблицу на новом или существующем листе, и обязательно установите флажок «Добавить эти данные в модель данных» .
  1. Когда откроется сводная таблица, расположите области строк, столбцов и значений так, как вам нужно. Если у вас нет большого опыта работы со сводными таблицами Excel, могут оказаться полезными следующие подробные рекомендации: Создание сводной таблицы в Excel.
  2. Переместите поле, количество уникальных элементов которого вы хотите вычислить ( поле « Товар» в этом примере), в область « Значения» , щелкните его и выберите «Параметры значения поля…» из раскрывающегося меню.
  3. Откроется диалоговое окно , прокрутите вниз до операции «Число разных элементов» , которая является самым последним пунктом в списке, выберите ее и нажмите OK .

Вы также можете дать собственное имя своему счетчику, если хотите.

Готово! Вновь созданная сводная таблица будет отображать количество различных товаров, как показано на самом первом скриншоте в этом разделе.

Вот как можно подсчитать различные и уникальные значения в столбце и целиком в таблице Excel. 

Благодарю вас за чтение и надеюсь увидеть вас снова. Пожалуйста, не переключайтесь!

Подсчитать количество ячеек, содержащих числовые или нечисловые значения в Excel

Если у вас есть диапазон данных, который содержит как числовые, так и нечисловые значения, и теперь вы можете подсчитать количество числовых или нечисловых ячеек, как показано на скриншоте ниже. В этой статье я расскажу о некоторых формулах решения этой задачи в Excel.

Количество ячеек, содержащих числовые значения

В Excel функция COUNT может помочь вам подсчитать количество ячеек, содержащих только числовые значения, общий синтаксис:

=COUNT(range)

range: Диапазон ячеек, которые вы хотите подсчитать.

Введите или скопируйте приведенную ниже формулу в пустую ячейку и нажмите Enter чтобы получить количество числовых значений, как показано на скриншоте ниже:

=COUNT(A2:C9)

Количество ячеек, содержащих нечисловые значения

Если вы хотите получить количество ячеек, содержащих нечисловые значения, функции СУММПРОИЗВ, НЕ и ЕЧИСЛО вместе могут решить эту задачу, общий синтаксис следующий:

=SUMPRODUCT(—NOT(ISNUMBER(range)))

range: Диапазон ячеек, которые вы хотите подсчитать.

Введите или скопируйте следующую формулу в пустую ячейку, а затем нажмите клавишу Enter, и вы получите общее количество ячеек с нечисловыми значениями и пустыми ячейками, см. Снимок экрана:

=SUMPRODUCT(—NOT(ISNUMBER(A2:C9)))

Пояснение к формуле:
  • ЕЧИСЛО (A2: C9): Эта функция ЕЧИСЛО выполняет поиск чисел в диапазоне A2: C9 и возвращает ИСТИНА или ЛОЖЬ. Итак, вы получите такой массив: {ИСТИНА, ИСТИНА, ЛОЖЬ; ЛОЖЬ, ЛОЖЬ, ИСТИНА; ИСТИНА, ЛОЖЬ, ЛОЖЬ; ЛОЖЬ, ИСТИНА, ЛОЖЬ; ЛОЖЬ, ЛОЖЬ, ЛОЖЬ; ИСТИНА, ЛОЖЬ, ИСТИНА; ИСТИНА, ИСТИНА, ЛОЖЬ; ЛОЖЬ, ЛОЖЬ, ИСТИНА}.
  • НЕ (ЕЧИСЛО (A2: C9)): Эта функция НЕ преобразует результат массива в обратную сторону. И результат будет таким: {ЛОЖЬ, ЛОЖЬ, ИСТИНА; ИСТИНА, ИСТИНА, ЛОЖЬ; ЛОЖЬ, ИСТИНА, ИСТИНА; ИСТИНА, ЛОЖЬ, ИСТИНА; ИСТИНА, ИСТИНА, ИСТИНА; ЛОЖЬ, ИСТИНА, ЛОЖЬ; ЛОЖЬ, ЛОЖЬ, ИСТИНА; ИСТИНА, ИСТИНА, ЛОЖЬ}.
  • —НЕТ (НОМЕР (A2: C9)): Этот двойной отрицательный оператор — преобразует вышеуказанный TURE в 1 и FALSE в 0 в массиве, и вы получите следующий результат: {0,0,1; 1,1,0; 0,1,1; 1,0,1, 1,1,1; 0,1,0; 0,0,1; 1,1,0; XNUMX}.
  • SUMPRODUCT(—NOT(ISNUMBER(A2:C9)))= SUMPRODUCT({0,0,1;1,1,0;0,1,1;1,0,1;1,1,1;0,1,0;0,0,1;1,1,0}): Наконец, функция СУММПРОИЗВ складывает все числа в массиве и возвращает окончательный результат: 14.

Советы: С помощью приведенной выше формулы вы увидите, что все пустые ячейки также будут подсчитаны, если вы просто хотите получить нечисловые ячейки без пробелов, приведенная ниже формула может вам помочь:

Используемая относительная функция:

  • СЧИТАТЬ:
  • Функция COUNT используется для подсчета количества ячеек, содержащих числа, или для подсчета чисел в списке аргументов.
  • SUMPRODUCT:
  • Функцию СУММПРОИЗВ можно использовать для умножения двух или более столбцов или массивов вместе, а затем получения суммы произведений.
  • НЕ:
  • Функция НЕ возвращает обратное логическое значение.
  • НОМЕР:
  • Функция ЕЧИСЛО возвращает ИСТИНА, если ячейка содержит число, и ЛОЖЬ, если нет.

Другие статьи:

  • Подсчитать количество ячеек, содержащих определенный текст в Excel
  • Предположим, у вас есть список текстовых строк, и вы можете захотеть найти количество ячеек, которые содержат определенный текст как часть своего содержимого. В этом случае вы можете использовать подстановочные знаки (*), которые представляют любые тексты или символы в ваших критериях при применении функции СЧЁТЕСЛИ. В этой статье я расскажу, как использовать формулы для решения этой задачи в Excel.
  • Подсчитайте количество ячеек, не равное множеству значений в Excel
  • В Excel вы можете легко получить количество ячеек, не равное определенному значению, используя функцию СЧЁТЕСЛИ, но пробовали ли вы когда-нибудь подсчитать количество ячеек, которые не равны множеству значений? Например, я хочу получить общее количество продуктов в столбце A, но исключить конкретные элементы в C4: C6, как показано на скриншоте ниже. В этой статье я представлю несколько формул для решения этой задачи в Excel.
  • Подсчитайте количество ячеек, содержащих нечетные или четные числа
  • Как все мы знаем, остаток нечетных чисел равен 1 при делении на 2, а остаток четных чисел равен 0 при делении на 2. В этом уроке я расскажу о том, как получить количество ячеек, содержащих нечетные или четные. числа в Excel.

С определенным текстом или значением

Функция СЧЁТЕСЛИ – позволяет рассчитать количество блоков, которые соответствуют заданному критерию. В качестве аргумента прописывается диапазон – В2:В13, и через «;» указывается критерий – «>5».

Например, есть таблица, в которой указано, сколько килограмм определенного товара было продано за день. Посчитаем, сколько товаров было продано весом больше 5 килограмм. Для этого нужно посчитать сколько блоков в столбце Вес, где значение больше пяти. Функция будет выглядеть следующим образом: =СЧЁТЕСЛИ(В2:В13;»>5″). Она рассчитает количество блоков, содержимое в которых больше пяти.

Для того чтобы растянуть функцию на другие блоки, и скажем поменять условия, необходимо закрепить выбранный диапазон. Сделать Вы это сможете, используя абсолютные ссылки в Excel.

Функция также может рассчитать:

– количество ячеек с отрицательными значениями: =СЧЁТЕСЛИ(В2:В13;» – количество блоков, содержимое в которых больше (меньше) чем в А10 (для примера): =СЧЁТЕСЛИ(В2:В13;»>»&A10); – ячейки, значение в которых больше 0: =СЧЁТЕСЛИ(В2:В13;»>0″); – непустые блоки из выделенного диапазона: =СЧЁТЕСЛИ(В2:В13;»»).

Применять функцию СЧЁТЕСЛИ можно и для расчета ячеек в Excel, содержащих текст. Например, рассчитаем, сколько в таблице фруктов. Выделим область и в качестве критерия укажем «фрукт». Будут посчитаны все блоки, с данным словом. Можно не писать текст, а просто выделить прямоугольник, который его содержит, например С2.

Для формулы СЧЁТЕСЛИ регистр не имеет значения, будут подсчитаны ячейки содержащие текст «Фрукт» и «фрукт».

В качестве критерия также можно   использовать специальные символы: «*» и «?». Они применяются только к тексту.

Посчитаем сколько товаров начинается на букву А: «А*». Если указать «абрикос*», то учтутся все товары, которые начинаются с «абрикос»: абрикосовый сок, абрикосовое варенье, абрикосовый пирог.

Символом «?» можно заменить любую букву в слове. Написав в критерии «ф?укт» – учтутся слова фрукт, фуукт, фыукт.

Чтобы посчитать слова в ячейках, которые состоят из определенного количества букв, поставьте знаки вопросов подряд. Для подсчета товаров, в названии которых 5 букв, поставим в качестве критерия «?????».

Если в качестве критерия поставить звездочку, из выбранного диапазона будут посчитаны все блоки, содержащие текст.

Как в Эксель посчитать количество значений и чисел

Чтобы посчитать количество чисел в массиве, используйте функцию . Вы можете задать список значений через точку с запятой, или целый массив сразу:

Считаем числовые значения

Если нужно определить количество ячеек, содержащих значения, воспользуемся функцией . В отличие от предыдущей функции, она посчитает не только числа, а и любые комбинации символов. Если ячейка непустая – она будет посчитана. Если в ячейке формула, которая возвращает ноль или пустую строку – функция ее тоже включит в свой результат.

Посчитать непустые ячейки

Как посчитать ячейки с условием в Microsoft Excel

Если нужно посчитать ячейки, которые удовлетворяют какому-то условию, используйте функцию . Здесь 2 обязательных аргумента:

  • Массив – диапазон ячеек, среди которых производится подсчет. Можно задавать только прямоугольный диапазон смежных ячеек;
  • Критерий – условие, по которому происходит отбор. Текстовые условия и числовые со знаками сравнения запишите в кавычках. Равенство числу записываем без кавычек. Например:
    • «>0» – считаем ячейки с числами больше нуля
    • «Excel» – считаем ячейки, в которых записано слово «Excel»
    • 12 – счет ячеек с числом 12

Счет ячеек с условием

Если нужно учесть несколько условий, используйте функцию . Функция может содержать до 127 пар «массив-критерий».

Если вы в используете разные массивы в одной такой функции – все они должны содержать одинаковое количество строк и столбцов.

Счет значений по нескольким условиям

Подсчет количества уникальных значений

Постановка задачи

​С помощью оператора​«СЧЁТЗ»​ заполненных значениями ячеек​ состояния.​

​ вкусом. К сожалению​ полей, удаление (СЖПРОБЕЛЫ)​. Если представить это​ повторяющихся данных.​ разница не заметна.​на самом деле​Решение​жирным​

​ превышающие 150.​ обрабатывали ранее.​

Способ 1. Если нет пустых ячеек

​«OK»​ непустых элементов в​ окне предыдущей функции,​СЧЁТ​. После этого производим​ и нельзя задавать​

​Для выполнения данной задачи​ не могу по​ мути?… А использование​ в виде дополнительного​Пример ниже.​200?’200px’:»+(this.scrollHeight+5)+’px’);»>=СУММ(СЧЁТЕСЛИ(O5:O11;A8:H8))​

​ содержатся 4 значения​Запишем формулу =СУММПРОИЗВ((A7:A15<>»»)/СЧЁТЕСЛИ(A7:A15;A7:A15))​).​Далее, как всегда, жмем​В поле​.​ диапазоне, а в​​ тоже может быть​ ​можно произвести подсчет​​ щелчок по кнопке​ условия подсчета.​ достаточно зажать левую​ достоинству оценить пост​

​ азбучных подходов: расширенный​​ столбца, то выглядело​​buchlotnik​megavlom​ «», которые воспринимаются​Если в диапазоне кроме​Если исходный список значений​

Способ 2. Если есть пустые ячейки

​ на кнопку​«Критерий»​Производится активация окошка аргументов​ нашем случае в​ представлено до 255​ только числовых значений​«OK»​С помощью оператора​

​ кнопку мыши и​

planetaexcel.ru>

Нулевые строки.

Также имейте в виду, что СЧЕТЕСЛИ и СЧИТАТЬПУСТОТЫ считают ячейки с пустыми строками, которые только на первый взгляд выглядят пустыми.

Что такое эти пустые строки? Они также часто возникают при импорте данных из других программ (например, 1С). Внешне в них ничего нет, но на самом деле это не так. Если попробовать найти такие “пустышки” (F5 -Выделить – Пустые ячейки) – они не определяются. Но фильтр данных при этом их видит как пустые и фильтрует как пустые.

Дело в том, что существует такое понятие, как «строка нулевой длины» (или «нулевая строка»). Нулевая строка возникает, когда программе нужно вставить какое-то значение, а вставить нечего.

Проблемы начинаются тогда, когда вы пытаетесь с ней произвести какие-то математические вычисления (вычитание, деление, умножение и т.д.). Получите сообщение об ошибке #ЗНАЧ!. При этом функции СУММ и СЧЕТ их игнорируют, как будто там находится текст. А внешне там его нет.

И самое интересное – если указать на нее мышкой и нажать Delete (или вкладка Главная – Редактирование – Очистить содержимое) – то она становится действительно пустой, и с ней начинают работать формулы и другие функции Excel без всяких ошибок.

Если вы не хотите рассматривать их как пустые, используйте для подсчета реально пустых клеток следующее выражение:

Откуда могут появиться нулевые строки в ячейках? Здесь может быть несколько вариантов:

  1. Он есть там изначально, потому что именно так настроена выгрузка и создание файлов в сторонней программе (вроде 1С). В некоторых случаях такие выгрузки настроены таким образом, что как таковых пустых ячеек нет – они просто заполняются строкой нулевой длины.
  2. Была создана формула, результатом которой стал текст нулевой длины. Самый простой случай:

=ЕСЛИ(Е1=1;10;””)

В итоге, если в Е1 записано что угодно, отличное от 1, программа вернет строку нулевой длины. И если впоследствии формулу заменять значением (Специальная вставка – Значения), то получим нашу псевдо-пустую позицию.

Если вы проверяете какие-то условия при помощи функции ЕСЛИ и в дальнейшем планируете производить с результатами математические действия, то лучше вместо “” ставьте 0. Тогда проблем не будет. Нули всегда можно заменить или скрыть: Файл -Параметры -Дополнительно – Показывать нули в позициях, которые содержат нулевые значения.

Как посчитать промежуточные итоги

Одна из частых ситуаций, с которой сталкиваются люди, активно работающие в таблицах Excel, – необходимость посчитать промежуточные итоги в одном рабочем документе. Как и в случае с общим итогом, сделать это можно вручную. Однако программа позволяет автоматизировать свои действия, быстро получить требуемый результат. Существует несколько требований, которым должна соответствовать таблица для расчета промежуточных итогов:

  1. При создании шапки столбца нельзя вписывать в ней несколько строк. Одновременно с этим шапка должна быть расположена на первой строке рабочей таблицы.
  2. Невозможно получить промежуточные итоги в тех столбцах, внутри которых находятся пустые ячейки. Даже при наличии одной пустой клетки во всей таблице, расчет произведен не будет.
  3. Рабочий документ должен иметь стандартный диапазон без форматирования.

Сам процесс расчета промежуточных итогов состоит из нескольких действий:

  1. В первую очередь нужно распределить данные в первом столбце так, чтобы они распределились на группы одинакового типа.
  2. Левой кнопкой мыши выбрать любую произвольную ячейку рабочей таблицы.
  3. Перейти во вкладку “Данные” на основной странице с инструментами.
  4. В разделе “Структура” нажать на функцию “Промежуточные итоги”.
  5. После осуществления данных действий на экране появится окно, в котором необходимо прописать параметры для дальнейшего расчета.

В параметре “Операция” необходимо выбрать раздел “Сумма” (есть возможность выбора других математических действий). В следующем параметре указать те столбцы, для которых будут высчитываться промежуточные итоги. Для сохранения указанных параметров необходимо нажать кнопку “ОК”. После выполнения описанных выше действий, между каждой группой ячеек появится одна промежуточная, в которой будет указан результат, полученный после осуществления расчета.

Как удалить промежуточные итоги

Необходимость в существовании промежуточных итогов со временем полностью пропадает. Чтобы лишние значения не отвлекали человека во время работы, таблица получила изначальную целостность, нужно удалить результаты расчетов с их дополнительными строчками. Для этого необходимо выполнить несколько действий:

  1. Зайти во вкладку “Данные” на главной странице с инструментами. Нажать на функцию “Промежуточный итог”.
  2. В появившемся окне необходимо отметить галочкой пункт “Размер”, нажать на кнопку “Убрать все”.
  3. После этого все добавленные данные вместе с дополнительными ячейками будут удалены.
Гость форума
От: admin

Эта тема закрыта для публикации ответов.