Количество символов в ячейке в эксель

Алан-э-Дейл       07.09.2022 г.

Оглавление

Функция СЧЕТ (COUNT) в Excel

​ аргументов, каждый из​​При подсчете текстовых значений​ количество любых символов.​ выражен как 32,​ и могут пригодиться​СЧЕТЕСЛИ​ ячейки, содержащие только​ очень удобно применить​, расположенную в верхней​ учтено сразу​ я что то​​ 1 до 11,​​Формула: =СЧЁТЕСЛИ(A1:A11;»<>»&»стулья»). Оператор «<>»​

Синтаксис функции СЧЕТ

​ ячейки (обязательный).​

​: Макрофункции — это​

​значение​: Доброго времени суток.​ которых способен содержать​ убедитесь в том,​ Результат — 4.​ «>32», В4, «яблоки»​ практически в любой​

​позволяет подсчитывать ячейки,​​ числовые значения, а​ функцию автосуммы.​ части окна слева​пробовал формулу, но​ не правильно применил?​

​ указывающие статистическую функцию​ означает «не равно».​В диапазоне ячеек могут​ не ВБА, как​(то есть формат​2003​ огромное количество данных.​ что данные не​=СЧЁТЕСЛИ(A2:A5;»????ки»)​ или «32».​ ситуации. Надеюсь, что​

Какие значения считаются числовыми

​ содержащие текстовые значения.​ в некоторых случаях,​Подсчитаем количество знаков для​ от строки формул.​ с ней тоже​PS в массиве​ для расчета промежуточного​ Знак амперсанда (&)​ находиться текстовые, числовые​ Вы его понимаете​

  • ​ ячейки не текстовый)?​вопрос 1-й​ В более ранних​
  • ​ содержат начальных или​Количество ячеек, строка в​В функции СЧЁТЕСЛИ используется​ данный урок открыл​ Например, следующая формула​
  • ​ их содержимое должно​ каждой отдельной ячейки,​Запускается Мастер функций. Ищем​ не все так​ есть фрагмент -​ результата. Подсчет количества​ объединяет данный оператор​ значения, даты, массивы,​Hugo​kim​водоотвод​

​ версиях Excel (например,​ конечных пробелов, недопустимых​ которых содержит ровно​ только один критерий.​ для Вас все​

Полезная информация

  • ​ возвращает количество ячеек​ отвечать определенным критериям.​ как это было​
  • ​ в нем наименование​ просто.​ «ПОДСТАВИТЬ» что это​ ячеек осуществляется под​
  • ​ и значение «стулья».​ ссылки на числа.​: VBA​:​

Примеры использования функции СЧЕТ в Excel

  1. ​кол-во букв «о»​ Excel 2003 года),​ прямых и изогнутых​ 7 знаков и заканчивается​ Чтобы провести подсчет​ тайны функций​ со словом «текст»,​
  2. ​ В этом уроке​ описано в предыдущем​ДЛСТР​применил ее к​ и как работает​ цифрой «2» (функция​При применении ссылки формула​ Пустые ячейки функция​
  3. ​Запятую грубо уничтожаем.​0mega​ ?​ функция СЧЕТ обрабатывала​ кавычек или непечатаемых​ буквами «ки», в​ по нескольким условиям,​

​СЧЕТ​ причем регистр не​​ мы подробно разберем​

​ варианте.​

office-guru.ru>

Как посчитать количество символов в ячейке Excel.

​ пробелов в текстовой​​ напишем такую формулу.​Второй способ.​ ​ варианте. Затем, функцией​​ ячейке​​ ячейке А49. =ДЛСТР(A49)​​.​​В Excel нет​​ в ячейки B3​​Подсчет символов в одной​​cell1​​ 2.​​ содержать неточности и​​нашла уже, спасибо​Примечание. В формуле используется​ слов:​ ДЛСТР.​ строке всегда на​=СУММПРОИЗВ(ДЛСТР(A66:A68)-ДЛСТР(ПОДСТАВИТЬ(A66:A68;»с»;»»)))​Нам нужно посчитать​ «Автосумма» складываем эти​Excel​Копируем формулу по​​У нас такая​ ​ специальной кнопки подсчета​​ и B4, а​​ ячейке​​), функция LEN (​ ​Чтобы использовать функцию, введите​​ грамматические ошибки. Для​ LEN​ функция ПРОПИСН чтобы​Практическое применения выше описных​Сначала функция ДЛСТР проверяет​ единицу меньше чем​Получится так.​ в словах количество​ значения отдельных ячеек.​​.​​ столбцу. Какими способами​​ таблица.​ количества символов в​ ​ функция подсчитает символы​​Щелкните ячейку B2.​​cell2​= ДЛСТР (​


​ сочинить формулу для​​ фраз.​​ = количество пробелов​ символы, но и​​ С66 напишем такую​​ слова. Какую формулу​​ Получится такая формула.​ числам в ячейках​​Получилось так.​​Ниже приведены некоторые примеры​​ нам нужна формула​​ сразу во всех​​ «Итого», которая содержит​ того, как работает​​Нескольких ячеек:​​ в ячейках Excel?​​ функция ДЛСТР.​​Скопируйте приведенную ниже таблицу​

excel-office.ru>

Как извлечь подстроку после последнего вхождения разделителя

При работе со сложными текстовыми выражениями, которые содержат несколько вхождений одного и того же разделителя, вам часто может потребоваться получить текст справа от последнего появления разделителя. Чтобы упростить понимание, взгляните на следующие исходные данные и желаемый результат:рис4

Как вы можете видеть на скриншоте выше, столбец A содержит список ошибок. Ваша цель — получить описание ошибки, которое идет после последнего двоеточия. Дополнительная сложность заключается в том, что исходные значения могут содержать разное количество разделителей, например, A3 содержит 3 двоеточия, а A5 — только одно.

Ключом к поиску решения является определение позиции последнего разделителя (последнее вхождение двоеточия в этом примере). Для этого вам нужно будет выполнить несколько несложных операций:

  1. Подсчитайте количество разделителей в исходной строке. Это несложно:
    • Вычисляете общую ее длину с помощью ДЛСТР(A2).
    • Определяем длину без разделителей, используя формулу ПОДСТАВИТЬ, которая заменяет все вхождения двоеточия ничем: ДЛСТР(ПОДСТАВИТЬ(A2; «:»; «»))
    • Наконец, вы вычитаете длину исходной строки без разделителей из общей длины:  ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;»:»;»»))

Чтобы убедиться, что формула работает правильно, вы можете ввести ее в отдельную ячейку, и результатом будет 2, то есть количество двоеточий в ячейке A2.

  1. Замените последний разделитель на какой-нибудь уникальный символ. Чтобы извлечь текст, который идет после последнего разделителя, нам нужно каким-то образом «пометить» это последнее вхождение разделителя. Для этого давайте заменим последнее вхождение двоеточия символом, который нигде не встречается в исходных значениях, например, знаком доллара ($).

Если вы знакомы с синтаксисом функции ПОДСТАВИТЬ, вы можете помнить, что у нее есть 4-й необязательный аргумент (номер вхождения), который позволяет заменять только конкретное появление указанного символа. И поскольку мы уже вычислили количество разделителей, просто впишите рассмотренное выше выражение в четвертый аргумент функции ПОДСТАВИТЬ:

Если вы поместите эту формулу в отдельную ячейку, она вернет:          ERROR: 432 $ Connection timed out

  1. Определяем позицию последнего разделителя. В зависимости от того, на какой символ вы заменили последний разделитель, используйте ПОИСК (без учета регистра) или НАЙТИ (с учетом регистра), чтобы определить позицию этого символа. Мы заменили последнее двоеточие на знак $, поэтому используем следующую формулу, чтобы узнать его местоположение:

ПОИСК(«$»; ПОДСТАВИТЬ(A2;»:»;»$»;ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;»:»;»»)))))

В этом примере формула возвращает 10, что является позицией $ в измененном тексте.

  1. Получаем подстроку справа от последнего разделителя. Теперь, когда вы знаете позицию последнего разделителя, все, что вам нужно сделать, это вычесть это число из общей длины строки и использовать ПРАВСИМВ, чтобы вернуть это количество символов из конца исходного текста:

ПРАВСИМВ(A2;ДЛСТР(A2)-ПОИСК(«$»; ПОДСТАВИТЬ(A2;»:»;»$»;ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;»:»;»»)))))

Если вы работаете с большим набором данных, где разные ячейки могут содержать различные разделители, вы можете заключить приведенную выше формулу в функцию ЕСЛИОШИБКА, чтобы предотвратить возможные сообщения об ошибках:

Как показано на скриншоте ниже, формула работает отлично:

Замечание. В случае, если ячейка не содержит ни одного вхождения указанного разделителя, будет возвращена исходная строка целиком.

Не работает ЛЕВСИМВ — причины и решения

Если ЛЕВСИМВ не работает на ваших листах должным образом, это, скорее всего, связано с одной из причин, которые мы перечислим ниже.

1. Аргумент «количество знаков» меньше нуля

Если ваша формула возвращает ошибку #ЗНАЧ!, то первое, что вам нужно проверить, — это значение аргумента количество_знаков. Если вы видите отрицательное число, просто удалите знак минус, и ошибка исчезнет (конечно, очень маловероятно, что кто-то намеренно поставит отрицательное число, но человек может ошибиться 🙂

Чаще всего ошибка #ЗНАЧ! возникает, когда этот аргумент получен в результате вычислений, а не записан вручную. В этом случае скопируйте это вычисление в другую ячейку или выберите его в строке формул и нажмите F9, чтобы увидеть результат ее работы. Если значение меньше 0, проверьте на наличие ошибок.

Чтобы лучше проиллюстрировать эту мысль, возьмем формулу, которую мы записали в первом примере для извлечения телефонных кодов страны:

ЛЕВСИМВ(A2; ПОИСК(«-«; A2)-1)

Как вы помните, функция ПОИСК в наших примерах вычисляет позицию первого дефиса в исходной строке, из которой мы затем вычитаем 1, чтобы удалить дефис из окончательного результата. Если я случайно заменю -1, скажем, на -11, Эксель выдаст ошибку #ЗНАЧ!, потому что нельзя извлечь отрицательное количество букв и цифр:

2. Начальные пробелы в исходном тексте

Если вы скопировали свои данные из Интернета или экспортировали из другого внешнего источника, довольно часто такие неприятные сюрпризы попадаются в самом начале текста. И вы вряд ли заметите, что они там есть, пока что-то не пойдет не так. Следующее изображение иллюстрирует проблему:

Чтобы избавиться от ведущих пробелов на листах, воспользуйтесь СЖПРОБЕЛЫ (TRIM).

3. ЛЕВСИМВ не работает с датами.

Если вы попытаетесь использовать ЛЕВСИМВ для получения отдельной части даты (например, дня, месяца или года), в большинстве случаев вы получите только первые несколько цифр числа, представляющего эту дату. Дело в том, что в Microsoft Excel все даты хранятся как числа, представляющие количество дней с 1 января 1900 года. То, что вы видите в ячейке, это просто визуальное представление даты. Ее отображение можно легко изменить, применив другой формат.

Например, если у вас есть дата 15 июля 2020 года в ячейке A1 и вы пытаетесь извлечь день с помощью выражения ЛЕВСИМВ(A1;2). Результатом будет 44, то есть первые 2 цифры числа 44027, которое представляет 15 июля 2020г. во внутренней системе Эксель.

Чтобы извлечь определенную часть даты, возьмите одну из следующих функций:  ДЕНЬ(),  МЕСЯЦ() или  ГОД().

Если же ваши даты вводятся в виде текстовых строк, то ЛЕВСИМВ будет работать без проблем, как показано в правой части скриншота:

Вот как можно использовать функцию ЛЕВСИМВ в Excel. 

Все описанные выше операции, а также многие другие действия с текстовыми значениями в Excel вы можете выполнить при помощи специального инструмента работы с текстом, включённого в надстройку Ultimate Suite. Вот только некоторые из этих возможностей: удалить лишние пробелы и ненужные символы, изменить регистр текста, подсчитать буквы и слова, добавить один и тот же текст в начало или конец всех ячеек в диапазоне, преобразовать текст в числа, разделить по ячейкам, извлечь отдельные слова, найти дубликаты слов.

Считаем с учетом всех критериев (логика И).

Этот вариант является самым простым, поскольку функция СЧЕТЕСЛИМН предназначена для подсчета только тех ячеек, для которых все указанные параметры имеют значение ИСТИНА. Мы называем это логикой И, потому что логическая функция И работает таким же образом.

а. Для каждого диапазона – свой критерий.

Предположим, у вас есть список товаров, как показано на скриншоте ниже. Вы хотите узнать количество товаров, которые есть в наличии (у них значение в столбце B больше 0), но еще не были проданы (значение в столбце D равно 0).

Задача может быть выполнена таким образом:

или

Видим, что 2 товара (крыжовник и ежевика) находятся на складе, но не продаются.

б. Одинаковый критерий для всех диапазонов.

Если вы хотите посчитать элементы с одинаковыми критериями, вам все равно нужно указывать каждую пару диапазон/условие отдельно.

Например, вот правильный подход для подсчета элементов, которые имеют 0 как в столбце B, так и в столбце D:

Получаем 1, потому что только Слива имеет значение «0» в обоих столбцах.

Использование упрощенного варианта с одним ограничением выбора, например =СЧЁТЕСЛИМН(B2:D11;0), даст другой результат – общее количество ячеек в B2: D11, содержащих ноль (в данном примере это 5).

посчитать сумму чисел и знаков в одной ячейке с условием

​ знаки

«?» -​​End If​​ будет результат вычисления​ есть формат ячейки​ Все зависит от​Примечание:​​ в кавычки.​=СЧЁТЕСЛИ(A2:A5;A4)​ важно, чтобы эта​

​ то используйте эту​ ​ который полностью состоит​ ​ сумму знаков во​ ​ аргумента и просто​

​P.S.​​0mega​​ нельзя подсчитать количество​​ на другую книгу,​​ «персики» (значение ячейки​ полезна. Просим вас​

​Функция​​В следующем примере в​ существует и такой​​ области на листе.​​=СУММПРОИЗВ(ДЛСТР(M4:M31)-ДЛСТР(ПОДСТАВИТЬ(M4:M31;»?»;))+ПОДСТАВИТЬ(0&M4:M31;»?»;))​200?’200px’:»+(this.scrollHeight+5)+’px’);»>=СУММ(ЕСЛИ(ЕЧИСЛО(-ПСТР(M7:Q7;СТРОКА($1:$99);1));—ПСТР(M7:Q7;СТРОКА($1:$99);1)))-((СУММПРОИЗВ(ДЛСТР(M7:Q7)-ДЛСТР(ПОДСТАВИТЬ(M7:Q7;{«?»};»»)))))​

​Посчитаем число ячеек в​​ символов. Чтобы формула​End Sub​Оказывается , я​:​ массиве или введено​ ячеек с определенным​ появляется ошибка #ЗНАЧ!.​​ A4) в ячейках​ уделить пару секунд​СЧЕТЕСЛИ​ двух ячейках диапазона​ вариант, в котором​ После этого её​для расчета и​считает и числа​и то и​​ диапазоне В1:В11 со​ искала непосредственно эти​_Boroda_​ так же не​to_Boroda_​ непосредственно в список​ фоном или цветом​​Эта ошибка возникает при​​ А2–А5. Результат — 1.​​позволяет использовать в​ содержится текст. Как​ все расчеты будут​​ адрес появится в​ знаков и цифр​ и знаки:))​ то работает криво.​ значением большим или​ знаки, ставим перед​

​: Формулами​​ могу выковырять цифры​,​​ аргументов.​​ шрифта. Однако Excel​​ вычислении ячеек, когда​​=СЧЁТЕСЛИ(A2:A5;A2)+СЧЁТЕСЛИ(A2:A5;A3)​ ли она вам,​ качестве условия даже​

​ видите, функция​​ проводиться в только​ поле. Когда данные​​Serge_007​ ДЛСТР считает количество​

​ равным 100 и​​ ними знак тильды​200?’200px’:»+(this.scrollHeight+5)+’px’);»>=СУММ(—(ЕЧИСЛО(-ПСТР(A1;СТРОКА(ДВССЫЛ(«A1:A»&ДЛСТР(A1)));1))+ЕОШИБКА(-ПСТР(A1&» «;СТРОКА(ДВССЫЛ(«A2:A»&ДЛСТР(A1)+1));1))=2))-СУММ(—(ЕЧИСЛО(-ПСТР(A1;СТРОКА(ДВССЫЛ(«A1:A»&ДЛСТР(A1)));1))+(ПСТР(A1&» «;СТРОКА(ДВССЫЛ(«A2:A»&ДЛСТР(A1)+1));1)=»,»)+ЕЧИСЛО(-ПСТР(A1&»»;СТРОКА(ДВССЫЛ(«A3:A»&ДЛСТР(A1)+2));1))=3))​ и из текста​Александр, здравствуйте​В таблице ниже представлено,​ поддерживает пользовательские функции,​

​ в формуле содержится​​Количество ячеек, содержащих текст​ с помощью кнопок​

​ формулы. К примеру,​​СЧЕТ​​ одной из них.​​ цифр:​​: Эта формула всегда​​ символов, с вопросами​ меньшим или равным​

​ (~).​​Последний кусок — исключительно​ …​Это идеальное решение первого​ какие значения функция​ в которых используются​ функция, которая ссылается​ «яблоки» (значение ячейки​ внизу страницы. Для​

​ чтобы посчитать количество​​их игнорирует.​​ В этом случае​

​ кнопку​​=СУММПРОИЗВ(ДЛСТР(M16:M17)-ДЛСТР(ПОДСТАВИТЬ(M16:M17;»?»;)))​ будет возвращать неправильный​ все ОК, а​ 200. Формула: =СЧЁТЕСЛИ(B1:B11;»>=100″)-СЧЁТЕСЛИ(B1:B11;»>200″).​Для нормального функционирования формулы​ для борьбы с​

​поэтому еще 1​​ вопроса​ СЧЕТ учитывает, как​ операции VBA (Visual​

​ на ячейки или​​ A2) и «апельсины»​ удобства также приводим​ ячеек, значения в​​А вот ячейки, содержащие​ нужно применять составную​«OK»​Числа отдельно среди​​ результат, за исключением​ цифры добавляют путаницу,​Применим в формуле СЧЕТЕСЛИ​ в ячейках с​ запятой. Если все​ доп вопрос​​Уточняю второй вопрос​​ числовые, а какие​​ Basic для приложений)​​ диапазон в закрытой​​ (значение ячейки A3)​​ ссылку на оригинал​​ которых больше среднего​​ значения даты и​​ формулу с использованием​.​​ знаков:​ случая, когда в​ он не разделяет​ несколько диапазонов. Это​

​ текстовыми значениями не​​ числа целые, то​

​Quote​​ нет.​​ над ячейками, выполняемые​ книге. Для работы​​ в ячейках А2–А5.​​ (на английском языке).​​ значения, можно воспользоваться​ времени, учитываются:​​ оператора​Как видим, после этого​​=СУММПРОИЗВ(—ПОДСТАВИТЬ(0&M16:M17;»?»;))​​ исходном диапазоне есть​ 1 от 9..​​ возможно, если диапазоны​

excelworld.ru>

​ должно пробелов или​

  • Как в excel сделать ячейку с выбором
  • Как поменять формат ячейки в excel на числовой
  • Excel добавить в ячейку символ
  • Excel вставка картинки в ячейку
  • Excel заменить символ
  • Excel количество символов в ячейке
  • Excel новый абзац в ячейке
  • Excel подсчет количества ячеек с определенным значением
  • Excel подсчитать количество символов в ячейке excel
  • Excel разделить содержимое ячейки в разные ячейки
  • Excel сложить значения ячеек в excel
  • Excel ссылка на ячейку на другом листе

Извлекаем слово, содержащее определенный символ.

В этом примере показана еще одна нестандартная формула Excel ПСТР, которая извлекает слово, содержащее определенную букву или цифру, из любого места:

Предполагая, что исходный текст находится в ячейке A2, и вы хотите получить слово, содержащее символ «$» (цена), выражение принимает следующую форму:

Аналогичным образом вы можете извлекать адреса электронной почты (на основе знака «@»), имена веб-сайтов (на основе «www») и так далее.

Теперь разберём пошагово:

Как и в предыдущем примере, ПОДСТАВИТЬ и ПОВТОР превращают каждый пробел в исходном тексте в несколько, точнее, в 99.

НАЙТИ находит позицию нужного символа (в данном примере $), из которой вы вычитаете 50. Это возвращает вас на 50 позиций назад и помещает где-то в середине блока из 99 пробелов, который предшествует слову, содержащему указанный символ.

МАКС используется для обработки ситуации, когда нужное значение появляется в начале исходного текста. В этом случае результат ПОИСК() — 50 будет отрицательным числом, а МАКС(1, ПОИСК() — 50) заменяет его на 1.

С этой начальной точки ПСТР отбирает следующие 99 знаков и возвращает интересующее нас слово, окруженное множеством пробелов. Как обычно, СЖПРОБЕЛЫ помогает избавиться от лишних из них, оставив только один.

Совет. Если извлекаемый отрезок очень большой, замените 99 и 50 на более крупные числа, например 1000 и 500.

Счет определенных символов в ячейке

​End If​​ не ВБА, как​​, здравствуйте​​- это не​​_Boroda_​​кол-во цифр ?​ вопроса имеют отличие​

​ с числами. ​​ вхождения буквы в​​Определим, сколько букв Z​​аррр​ темы в окно​ Format(Cells(i, 4), «‘0000000000000»)​

​End Sub​​ до 12-ти​ Excel показать количество​:​Next​ Вы его понимаете​Я прекрасно понимаю,​

​ набор случайных символов.​​:​кол-во математических знаков?​ в решении, тогда​

​Пусть в диапазоне​​ слове или в​

​ в слове Zigzag​: Спасибо!​ поиска и выбирайте,​Next i​Я определил сколько​Мне необходимо в​ определённых символов. В​

​kim​​MsgBox x​​Hugo​​ что этот вопрос​​Это совокупность математических​

​Quote​ (включая и «=»​​ просьба к модераторам​

​А7:A11​​ текстовой строке можно​​ (слово находится в​​Numit​​ что Вам больше​End Sub​ нулей добавить, но​​ столбец Е добавить​​ частности есть таблица​​,​​End Sub​​: VBA​​ не вписывается в​​ действий с конкретными​​(_Boroda_)200?’200px’:»+(this.scrollHeight+5)+’px’);»>Вы хотите выковырять​​ )​ перенести 2-ой вопрос​содержатся числа 1;​​ прочитать здесь.​​ ячейке​​: Помогите пожалуйста,​​ подходит.​​AVI​​ как заставить их​​ эти же числа​​ с размерами. Нужно​​Спасибо,​​_Boroda_​

​Запятую грубо уничтожаем.​​ =ЕСЛИ(…)​​ числами и ячейками.​​ кол-во цифр из​​кол-во цифр: A1=(​​ в отдельную тему​​ 22; 123; 8;​​Найдем количество вхождений определенного​A1​как формулой посчитать​Guest​​:​​ добавиться я не​ так, что бы​

​ суммировать сколько например​​Интересное решение со​​: Формулами​​200?’200px’:»+(this.scrollHeight+5)+’px’);»>Sub tt()​​Учитывая, то обстоятельство​ И если топнуть​ формулы, которая выдает​47​_Boroda_​​ 5. Формула, приведенная​ символа в диапазоне​).​​ количество знаков в​: Спасибо нашел!!! =ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;».»;»»))​_Boroda_​ знаю​

​ общее их количество​​ размеров L и​​ знаками​​200?’200px’:»+(this.scrollHeight+5)+’px’);»>=СУММ(—(ЕЧИСЛО(-ПСТР(A1;СТРОКА(ДВССЫЛ(«A1:A»&ДЛСТР(A1)));1))+ЕОШИБКА(-ПСТР(A1&» «;СТРОКА(ДВССЫЛ(«A2:A»&ДЛСТР(A1)+1));1))=2))-СУММ(—(ЕЧИСЛО(-ПСТР(A1;СТРОКА(ДВССЫЛ(«A1:A»&ДЛСТР(A1)));1))+(ПСТР(A1&» «;СТРОКА(ДВССЫЛ(«A2:A»&ДЛСТР(A1)+1));1)=»,»)+ЕЧИСЛО(-ПСТР(A1&»»;СТРОКА(ДВССЫЛ(«A3:A»&ДЛСТР(A1)+2));1))=3))​Dim s As​​ , что это​ на Enter то​ в ячейке​+В3-​: Пара вариантов по​ выше, вернет 5,​ ячеек.​Формула для подсчета символа​​ ячейке?​​ — работает как​, Е-мае, точно. Спасибо.​StoTisteg​ было 13, а​ сколько XL. Беда​

​ в ячейка А1​значение​2​

​ Z в слове​​Заранее спасибо​​ часы ))​​Марат​​:​ недостающие заменить нулями​ в том, что​: Помогите пожалуйста,​​ для борьбы с​ Long, x As​ серии «МНЕ ОБЯЗАТЕЛЬНО​ будет результат вычисления​(то есть формат​)/D5-​ вложении​ содержится две цифры​ содержится в диапазоне​ Zigzag (с учетом​mazayZR​Юрий М​: Добрый день​Cells(i, 5)=Cstr(Trim(Cells(i, 5)))​ в начале числа.​

​ формулы которые я​​как формулой посчитать​ запятой. Если все​ Long​ НАДО. Я СКОПИРУЮ​ (напр 53,6451)​ ячейки не текстовый)?​

​12​​=ДЛСТР(B1)-ДЛСТР(ПОДСТАВИТЬ(B1;B2;»»))​ 1 (в числах​А7:A11​

​ регистра), см. файл​​: =ДЛСТР(A1)​​: А если всегда​

​По второму — Вы​​ и три цифры​

​=ДЛСТР(A1) — ДЛСТР(ПОДСТАВИТЬ(A1;»Z»;»»))​: Спасибо, а то​ :-))​ Пример ячейка A1​ -1​​ 0000041533892, а 31404053​

​=СУММПРОИЗВ (ДЛСТР ($E$2:$E$47)-ДЛСТР​

​Заранее спасибо​​Code200?’200px’:»+(this.scrollHeight+5)+’px’);»>=СУММ(—(ЕЧИСЛО(-ПСТР(A1;СТРОКА(ДВССЫЛ(«A1:A»&ДЛСТР(A1)));1))+ЕОШИБКА(-ПСТР(A1&» «;СТРОКА(ДВССЫЛ(«A2:A»&ДЛСТР(A1)+1));1))=2))​

​s = «За​​ к «ХОЧУ ЗНАТЬ»​​ так же не​​0mega​​кол-во математических знаков?​​ хотите выковырять кол-во​​ 2 (в числах​ учетом РЕгиСТра), см.​

​Формула для подсчета символа​​ прям вся измучалась​​Сергей​​ «1.09» и A2​​Cells(i, 5)=»0″ &​

​ на 0000031404053​​ (ПОДСТАВИТЬ (ПРОПИСН ($E$2:$E$47);{«L»};»»)))​​mazayZR​​формулы массива​​ 2 дня оштрафовали​​ и еще сюда​ могу выковырять цифры​

excelworld.ru>

Как подсчитать количество значений, разделенных запятыми / тире, в ячейке в Excel?

Например, у вас есть ячейка, содержащая много запятых в Excel, как вы можете легко подсчитать общее количество всех запятых в этой ячейке? В этой статье представлены два метода быстрого решения этой проблемы!

Подсчитайте количество запятых / тире в ячейке с формулой

Этот метод представит формулу для быстрого подсчета общего количества всех запятых или тире в одной ячейке в Excel. Пожалуйста, сделайте следующее:

Выберите ячейку, в которую вы поместите результат подсчета, введите формулу = LEN (A2) -LEN (ПОДСТАВИТЬ (A2; «,», «»)) (A2 — это ячейка, в которой вы будете считать запятые), а затем перетащите маркер автозаполнения этой ячейки в нужный диапазон. Смотрите скриншот:

Примечание. Для подсчета количества дефисов замените запятые дефисами в формулах, как = LEN (A2) -LEN (ПОДСТАВИТЬ (A2; «-«; «»)).

Подсчитайте количество запятых / тире в ячейке с помощью формулы Kutools for Excel

Иногда вы не можете точно запомнить формулу. Здесь мы рекомендуем Считайте, сколько раз появляется слово формула Kutools for Excel, которая поможет вам быстро подсчитать символ или слово в ячейке. Пожалуйста, сделайте следующее:

Kutools for Excel — Включает более 300 удобных инструментов для Excel. Полнофункциональная бесплатная 30-дневная пробная версия, кредитная карта не требуется! Бесплатная пробная версия сейчас!

1. Выберите пустую ячейку, в которую вы поместите результат подсчета, и нажмите Kutools > Формула Помощник > Статистически > Подсчитайте количество слова.

2. В открывшемся диалоговом окне Помощник по формулам укажите ячейку, в которой вы будете считать запятые / тире в Текст поле, введите , or — в Word и нажмите OK кнопка. Смотрите скриншот:

Затем подсчитывается общее количество запятых / тире в указанной ячейке и возвращается в выбранную ячейку. При необходимости перетащите маркер автозаполнения этой ячейки в нужный диапазон. Смотрите скриншот:

Внимание: Это Считайте, сколько раз появляется слово формула также может подсчитывать указанный символ или слово в диапазоне. См

Снимок экрана ниже:

Kutools for Excel — Включает более 300 удобных инструментов для Excel. Полнофункциональная бесплатная 30-дневная пробная версия, кредитная карта не требуется! Get It Now

Демонстрация: подсчитайте количество запятых / тире в ячейке / диапазоне

Kutools for Excel включает более 300 удобных инструментов для Excel, которые можно бесплатно попробовать без ограничений в течение 30 дней. Скачать и бесплатную пробную версию сейчас!

Выберите и подсчитайте ячейки, если они содержат определенный текст в Excel

Kutools для Excel Выберите определенные ячейки Функция может помочь нам быстро выбрать все ячейки, которые содержат, начинаются, заканчиваются или равны определенной текстовой строке в указанном диапазоне. Одновременно появится диалоговое окно, которое покажет нам, сколько ячеек было выбрано. Полнофункциональная бесплатная 30-дневная пробная версия!

Часто задаваемые вопросы и проблемы.

Я надеюсь, что эти примеры помогли вам почувствовать функцию Excel СЧЕТЕСЛИ. Если вы попробовали какую-либо из приведенных выше формул в своих данных и не смогли заставить их работать или у вас возникла проблема, взгляните на следующие 5 наиболее распространенных проблем. Есть большая вероятность, что вы найдете там ответ или же полезный совет.

  1. Возможен ли подсчет в несмежном диапазоне клеток?

Вопрос: Как я могу использовать СЧЕТЕСЛИ для несмежного диапазона или ячеек?

Ответ: Она не работает с несмежными диапазонами, синтаксис не позволяет указывать несколько отдельных ячеек в качестве первого параметра. Вместо этого вы можете использовать комбинацию нескольких функций СЧЕТЕСЛИ:

Неправильно: =СЧЕТЕСЛИ(A2;B3;C4;»>0″)

Правильно: = СЧЕТЕСЛИ (A2;»>0″) + СЧЕТЕСЛИ (B3;»>0″) + СЧЕТЕСЛИ (C4;»>0″)

Альтернативный способ — использовать функцию ДВССЫЛ (INDIRECT) для создания массива из несмежных клеток. Например, оба приведенных ниже варианта дают одинаковый результат, который вы видите на картинке:

=СУММ(СЧЁТЕСЛИ(ДВССЫЛ({«B2:B11″;»D2:D11″});»=0»))

Или же

=СЧЕТЕСЛИ($B2:$B11;0) + СЧЕТЕСЛИ($D2:$D11;0)

  1. Амперсанд и кавычки в формулах СЧЕТЕСЛИ

Вопрос: когда мне нужно использовать амперсанд?

Ответ: Это, пожалуй, самая сложная часть функции СЧЕТЕСЛИ, что лично меня тоже смущает. Хотя, если вы подумаете об этом, вы увидите — амперсанд и кавычки необходимы для построения текстовой строки для аргумента.

Итак, вы можете придерживаться этих правил:

Если вы используете число или ссылку на ячейку в критериях точного соответствия, вам не нужны ни амперсанд, ни кавычки. Например:

= СЧЕТЕСЛИ(A1:A10;10) или = СЧЕТЕСЛИ(A1:A10;C1)

Если ваши условия содержат текст, подстановочный знак или логический оператор с числом, заключите его в кавычки. Например:

= СЧЕТЕСЛИ(A2:A10;»яблоко») или = СЧЕТЕСЛИ(A2:A10;»*») или = СЧЕТЕСЛИ(A2:A10;»>5″)

Если ваши критерии — это выражение со ссылкой или же какая-то другая функция Excel, вы должны использовать кавычки («») для начала текстовой строки и амперсанд (&) для конкатенации (объединения) и завершения строки. Например:

= СЧЕТЕСЛИ(A2:A10;»>»&D2) или = СЧЕТЕСЛИ(A2:A10;»<=»&СЕГОДНЯ())

Если вы сомневаетесь, нужен ли амперсанд или нет, попробуйте оба способа. В большинстве случаев амперсанд работает просто отлично.

Например, = СЧЕТЕСЛИ(C2: C8;»<=5″) и = СЧЕТЕСЛИ(C2: C8;»<=»&5) работают одинаково хорошо.

  1. Как сосчитать ячейки по цвету?

Вопрос: Как подсчитать клетки по цвету заливки или шрифта, а не по значениям?

Ответ: К сожалению, синтаксис функции не позволяет использовать форматы в качестве условия. Единственный возможный способ суммирования ячеек на основе их цвета — использование макроса или, точнее, пользовательской функции Excel VBA.

  1. Ошибка #ИМЯ?

Проблема: все время получаю ошибку #ИМЯ? Как я могу это исправить?

Ответ: Скорее всего, вы указали неверный диапазон. Пожалуйста, проверьте пункт 1 выше.

  1. Формула не работает

Проблема: моя формула не работает! Что я сделал не так?

Ответ: Если вы написали формулу, которая на первый взгляд верна, но она не работает или дает неправильный результат, начните с проверки наиболее очевидных вещей, таких как диапазон, условия, ссылки, использование амперсанда и кавычек.

Будьте очень осторожны с использованием пробелов. При создании одной из формул для этой статьи я был уже готов рвать волосы, потому что правильная конструкция (я точно знал, что это правильно!) не срабатывала. Как оказалось, проблема была на самом виду… Например, посмотрите на это: =СЧЁТЕСЛИ(A4:A13;» Лимонад»). На первый взгляд, нет ничего плохого, кроме дополнительного пробела после открывающей кавычки. Программа отлично проглотит всё без сообщения об ошибке, предупреждения или каких-либо других указаний. Но если вы действительно хотите посчитать товары, содержащие слово «Лимонад» и начальный пробел, то будете очень разочарованы….

Если вы используете функцию с несколькими критериями, разделите формулу на несколько частей и проверьте каждую из них отдельно.

И это все на сегодня. В следующей статье мы рассмотрим несколько способов подсчитывания ячеек в Excel с несколькими условиями.

Ещё примеры расчета суммы:

Как извлечь имя и фамилию.

Если у вас была возможность прочитать наши недавние уроки, вы уже знаете, как вытащить имя с помощью функции ЛЕВСИМВ и получить фамилию с помощью ПРАВСИМВ.  Но, как это часто бывает в Excel, одно и то же можно сделать разными способами.

Получаем имя.

Предполагая, что полное имя находится в ячейке A2, имя и фамилия разделены интервалом, вы можете извлечь имя, используя следующую формулу:

ПОИСК используется для сканирования исходного значения на предмет пробела (» «) и возврата его позиции, из которой вы вычитаете 1, чтобы избежать пробелов после имени. Затем вы используете ПСТР, чтобы вернуть подстроку, начинающуюся с первого знака и заканчивая предшествующим пробелу, таким образом извлекая первое имя.

Получаем фамилию.

Чтобы извлечь фамилию из A2, используйте эту формулу:

Опять же, вы используете ПОИСК, чтобы определить начальную позицию (пробел). Нам не нужно точно рассчитывать конечную позицию (как вы помните, если вместе взятые начальная позиция и количество символов больше, чем общая длина текста, возвращаются просто все оставшиеся). Итак, в аргументе количество символов вы просто указываете общую первоначальную длину , возвращаемую функцией ДЛСТР . Впрочем, вместо этого вы можете просто ввести число, представляющее самую длинную фамилию, которую вы ожидаете найти, например 100. Наконец,  СЖПРОБЕЛЫ удаляет лишние интервалы, и вы получаете следующий результат:

Гость форума
От: admin

Эта тема закрыта для публикации ответов.