Формула в excel счет если

Алан-э-Дейл       08.04.2022 г.

Оглавление

Функция СЧЁТЕСЛИ() в MS Excel

Для подсчета ЧИСЛОвых значений, Дат и Текстовых значений, удовлетворяющих определенному критерию, существует простая и эффективная функция СЧЁТЕСЛИ(), английская версия COUNTIF(). Подсчитаем значения в диапазоне в случае одного критерия, а также покажем как ее использовать для подсчета неповторяющихся значений и вычисления ранга.

Синтаксис

СЧЁТЕСЛИ(диапазон;критерий)

Диапазон    — диапазон, в котором нужно подсчитать ячейки, содержащие числа, текст или даты.

Критерий    — критерий в форме числа, выражения, ссылки на ячейку или текста, который определяет, какие ячейки надо подсчитывать. Например, критерий может быть выражен следующим образом: 32, «32», «>32», «яблоки» или B4.

Подсчет числовых значений с одним критерием

Данные будем брать из диапазона A15:A25 (см. файл примера).

Критерий

Формула

Результат

Примечание

>=10

=СЧЁТЕСЛИ($A$2:$A$12; «>=10»)

4

Подсчитывает количество ячеек, содержащих числа равных или более 10. Критерий указан в формуле

<=10(ячейка С3)

=СЧЁТЕСЛИ( $A$2:$A$12;C3)

8

Подсчитывает количество ячеек, содержащих числа равных или меньших 10. Критерий указан через ссылку

>= (ячейка С4)11(ячейка С5)

=СЧЁТЕСЛИ($A$2:$A$12; C4&C5)

3

Подсчитывает количество ячеек, содержащих числа равных или более 11. Критерий указан через ссылку и параметр

Примечание. О подсчете значений, удовлетворяющих нескольким критериям читайте в статье Подсчет значений со множественными критериями. О подсчете чисел с более чем 15 значащих цифр читайте статью Подсчет ТЕКСТовых значений с единственным критерием в MS EXCEL.

Подсчет Текстовых значений с одним критерием

Функция СЧЁТЕСЛИ() также годится для подсчета текстовых значений (см. Подсчет ТЕКСТовых значений с единственным критерием в MS EXCEL).

Подсчет дат с одним критерием

Так как любой дате в MS EXCEL соответствует определенное числовое значение, то настройка функции СЧЕТЕСЛИ() для дат не отличается от рассмотренного выше примера (см. файл примера Лист Даты). 

Если необходимо подсчитать количество дат, принадлежащих определенному месяцу, то нужно создать дополнительный столбец для вычисления месяца, затем записать формулу =СЧЁТЕСЛИ(B20:B30;2)

Подсчет с несколькими условиями

Обычно, в качестве аргумента критерий у функции СЧЁТЕСЛИ() указывают только одно значение. Например, =СЧЁТЕСЛИ(h3:h21;I2). Если в качестве критерия указать ссылку на целый диапазон ячеек с критериями, то функция вернет массив. В файле примера формула =СЧЁТЕСЛИ(A16:A25;C16:C18) возвращает массив {3:2:5}.

 

Для ввода формулы выделите диапазон ячеек такого же размера как и диапазон содержащий критерии. В Строке формул введите формулу и нажмите CTRL+SHIFT+ENTER, т.е. введите ее как формулу массива.

Это свойство функции СЧЁТЕСЛИ() используется в статье Отбор уникальных значений.

Специальные случаи использования функции

Возможность задать в качестве критерия несколько значений открывает дополнительные возможности использования функции СЧЁТЕСЛИ().

В файле примера на листе Специальное применение показано как с помощью функции СЧЁТЕСЛИ() вычислить количество повторов каждого значения в списке.

Выражение СЧЁТЕСЛИ(A6:A14;A6:A14) возвращает массив чисел {1:4:4:4:4:1:3:3:3}, который говорит о том, что значение 1 из списка в диапазоне А6:А15 — единственное, также в диапазоне 4 значения 2, одно значение 3, три значения 4. Это позволяет подсчитать количество неповторяющихся значений формулой =СУММПРОИЗВ(—(СЧЁТЕСЛИ(A6:A14;A6:A14)=1)). 

Формула =СЧЁТЕСЛИ(A6:A14;»<«&A6:A14)+1 вычисляет ранг по убыванию для каждого числа из диапазона А6:А15. В этом можно убедиться, выделив формулу в Строке формул и нажав клавишу F9. Значения совпадут с вычисленным рангом в столбце В (с помощью функции РАНГ()). Этот подход применен в статьях Динамическая сортировка таблицы в MS EXCEL и Отбор уникальных значений с сортировкой в MS EXCEL.

Вариант 1: Счет текстовых условий

Разберем ситуацию, когда есть два столбца с определенными значениями, которыми в нашем случае выступают месяцы. Нужно сделать выборку из них, чтобы в результате показывало значение того, сколько ячеек соответствуют заданному условию. Объединяются два условия при помощи одной простой формулы.

  1. Создайте первую часть функции «СЧЁТЕСЛИ», указав в качестве диапазона первый столбец. Сама функция имеет стандартный вид: .

Добавьте знак сложения («+»), который и послужит соединительным для двух условий.

Сразу же после него впишите вторую часть — — и нажмите клавишу ввода.

Если нужно, дописывайте любое количество плюсов, добавляя диапазоны и критерии точно в таком же ключе.

Проверьте результат, который отобразится в заданной клетке. Если вдруг возникла ошибка, удостоверьтесь в том, что вы правильно соблюли синтаксис функции, а ячейки в диапазоне имеют соответствующий формат.

Функция НАИБОЛЬШИЙ

Возвращает значение элемента, являвшегося n-ым наибольшим, из указанного множества элементов. Например, второй наибольший, четвертый наибольший.

Синтаксис: =НАИБОЛЬШИЙ(массив; n), где

  • массив – диапазон ячеек либо массив элементов, содержащий числовые значения. Текстовые и логические значения игнорируются.
  • n – натуральное число (кроме нуля), указывающее позицию элемента в порядке убывания. Если задать дробное число, то оно округляется до целого в большую сторону (дробные числа меньше единицы возвращают ошибку). Если аргумент превышает количество элементов множества, то функция возвращает ошибку.

Массив или диапазон НЕ обязательно должен быть отсортирован.

Пример использования:

На изображении приведено 2 диапазона. Они полностью совпадают, кроме того, что в первом столбце диапазон отсортирован по убыванию, он представлен для наглядности. Функция ссылается на диапазон ячеек во втором столбце и возвращает элемент, являющийся 3 наибольшим значением.

В данном примере используется диапазон с повторяющимися значениями. Видно, что ячейкам не назначаются одинаковые ранги, в случае их равенства.

Формула ЕСЛИ в Excel – примеры нескольких условий

Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются

Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2

они входят в интервал B2

При написании формулы легко запутаться, поэтому рекомендуется смотреть на всплывающую подсказку.

В конце нужно обязательно закрыть все скобки, иначе эксель выдаст ошибку

Суммирование по пустым и непустым ячейкам.

При анализе отчетов и других данных вам часто может потребоваться суммировать данные, соответствующие пустым или непустым клеткам таблицы.

Критерии
Описание

Пустые ячейки
«=»
Суммируйте числа, соответствующие пустым, которые не содержат абсолютно ничего — ни формулы, ни строки нулевой длины.
=СУММЕСЛИМН(C2:C10;A2:A10;»=»;B2:B10,»=») Суммируйте в C2:C10, если соответствующие ячейки в столбцах A и B абсолютно пусты.

«»
Суммируйте числа, соответствующие «визуально» пустым, включая те, которые содержат пустые строки, возвращаемые какой-либо другой функцией Excel (например, ячейки с формулой вроде = «»).
=СУММЕСЛИМН(C2:C10;A2:A10;»»;B2:B10,»»)   Суммируйте в C2:C10 с теми же параметрами, что и в приведенной выше формуле, но с пустыми строками.
Непустые ячейки
«»
Суммируйте числа, соответствующие непустым, включая строки нулевой длины.
=СУММЕСЛИМН(C2:C10;A2:A10;»»;B2:B10,»») Суммируйте в C2: C10, если соответствующие ячейки в столбцах A и B не пусты, включая ячейки с пустыми строками.

Суммируйте числа, соответствующие непустым, не включая строки нулевой длины.
=СУММ(C2:C10) — СУММЕСЛИМН(C2:C10;A2:A10;»»;B2:B10,»») или{=СУММ((C2:C10)*(ДЛСТР(A2:A10)>0)*(ДЛСТР(B2: B10)>0))} Если в столбцах A и B содержится текст ненулевой длины, тогда соответствующее число из C складывается. Внимание! Это формула массива! Фигурные скобки вводить не нужно!

А теперь давайте посмотрим, как вы можете использовать формулу СУММЕСЛИМН с «пустыми» и «непустыми» ячейками для реальных данных.

По покупателю «Красный» рассчитаем количество товара в невыполненных заказах. Для этого в столбце B ищем соответствующее название клиента, а в F – пустую ячейку. Если оба требования совпадают, складываем количество товара из столбца D.

или

Каждое из этих выражений дает верный результат – 144 единицы в заказе от 4 февраля.

Сумма нескольких условий.

А теперь давайте рассчитаем общую стоимость выполненных заказов по двум товарам.

Если мы просто добавим второй критерий в I3, и вместо I2 используем область I2:I3, то расчет будет неверным, поскольку в C2:C21 будем искать товар, в названии которого есть И «черный», И «молочный» одновременно. Ведь таких просто нет.

Поэтому первый вариант расчета таков:

Просто складываем выполненные заказы сначала по первому, а затем по второму наименованию.

Второй вариант: используем элемент массива критериев и функцию СУММ.

Как видите, результаты получены одинаковые. Выбирайте способ, который будет для вас проще и понятнее.

Ещё примеры расчета суммы:

Подсчет ячеек в Excel, используя функции СЧЕТ и СЧЕТЕСЛИ

​ Текст «столы» функция​ числами больше 100.​Диапазон – группа значений​К примеру, следующая формула​ больше содержимого ячейки​Статистическая функция​=СЧЁТЕСЛИ(А2:А9; «??????»)​ Excel. Примеры подстановочных​ формулы, результаты их​74,5​Данная функция принимает два​ преобразования типов (т.к.​ workaround от Microsoft​ в четвертой строке.​ то что я​gling​​ ячеек осуществляется под​​ ищет в ячейке​​ Формула: =СЧЁТЕСЛИ(B1:B11;»>100″). Диапазон​​ для анализа и​ подсчитывает ячейки, значения​ А4.​​СЧЕТ​​1​​ знаков:​​ выполнения, а так​​42​​ обязательных аргумента. Первый​

СЧЕТ()

​ умножение его уже​​ для Excel 2003:​​ Может из за​ искал​: Или так.​ цифрой «2» (функция​ А1. Текст «стулья»​ – В1:В11. Критерий​ подсчета (обязательный).​ которых больше нуля,​СЧЕТЕСЛИ​

​подсчитывает количество ячеек​Товары с наименованием длиной​Знак​ же напишем краткий​​14.05.2017​​ из них –​

​ выполняет):​ Подсчет чисел или​ этого не считает​

​AlexM​​Henesis​​ «СЧЕТ»).​ — на базе​ подсчета – «>100».​

​Критерий – условие, по​ но меньше 50:​позволяет подсчитывать ячейки,​ в списке аргументов,​​ всего в 6​​Описание​ поясняющий комментарий. Все​6​ диапазон, в котором​=СУММПРОИЗВ​ дат на основе​

​Andrey770​: Еще вариант решения,​: Это Вы предлагаете​Скачать примеры функции СЧЕТЕСЛИ​ критерия в ячейке​​ Результат:​​ которому нужно подсчитать​

СЧЕТЕСЛИ()

​Функция​​ содержащие текстовые значения.​​ которые содержат только​ символов​*​ ответы основаны на​Яблоки глостер​ будет подсчитываться количество​(​ проверки условия​

​: Нужно посчитать количество​ формула массива​ 1 критерий, поясняю,​ в Excel​

​ А2.​​Если условие подсчета внести​ ячейки (обязательный).​СЧЕТЕСЛИМН​ Например, следующая формула​ числовые значения. Например,​=СЧЁТЕСЛИ(D2:D9; «​Текст (любое количество символов)​

​ табличных данных, введенных​​54,2​​ ячеек, удовлетворяющих условию.​КОДСИМВ(A1:A10)=КОДСИМВ(«андрей»)​​Buckminster​​ по 2 диапазонам​​200?’200px’:»+(this.scrollHeight+5)+’px’);»>=СУММ(СЧЁТЕСЛИ(B4:B15;ИНДЕКС(E4:G10;;ПОИСКПОЗ(I3;E3:G3;))))​​ мне нужно чтобы​Формула нашла количество значений​Посчитаем число ячеек в​ в отдельную ячейку,​В диапазоне ячеек могут​

​позволяет подсчитывать ячейки,​ возвращает количество ячеек​ на рисунке ниже​3​​?​​ выше, и выполняются​34​Второй аргумент – условие,​

​)​: А можно учесть​В 1 диапазоне​илиКод200?’200px’:»+(this.scrollHeight+5)+’px’);»>=СУММ(СЧЁТЕСЛИ(B4:B100;ГПР(I3;E3:G10;СТРОКА(A2:A8);)))​ посчитало в столбце​

​ для группы «Стулья».​​ диапазоне В1:В11 со​​ можно в качестве​ находиться текстовые, числовые​ используя условие​ со словом «текст»,​ мы подсчитали количество​Количество ячеек с датой​Текст (количество символов соответствует​ на дату 16.05.2017.​

​15.05.2017​ которое может задаваться​* (A1:A10=»андрей») *​ регистр?​​ все с именем​​Nikola​ «припасы» количество совпадений​ При большом числе​ значением большим или​ критерия использовать ссылку:​

​ значения, даты, массивы,​И​ причем регистр не​ ячеек в диапазоне,​

​ закупки старше десяти​​ количеству знаков вопроса).​​Пример​7​​ в форме числа​​ (B$1:B$10)​Serge 007​ Андрей​​: Помогите решить проблему.​​ с значениями содержащимися​ строк (больше тысячи)​​ равным 100 и​​Посчитаем текстовые значения в​ ссылки на числа.​. Если же требуется​ имеет значения.​​ который полностью состоит​​ дней назад​​ Работает только с​​Ответ​

​Огурец китайский​ или слова, а​на самом деле​: Конечно​В 2 -​ версия экселя 2003​ в столбце к​ подобное сочетание функций​​ меньшим или равным​​ одном диапазоне. Условие​​ Пустые ячейки функция​​ подсчитать количество с​Логическое условие функции​​ из чисел:​​=СЧЁТЕСЛИ(С2:С9; «>» & СРЗНАЧ(С2:С9))​​ текстовыми данными! Если​​Комментарий​​64​​ также в форме​ было (дополнительные зелёные​Код =СУММПРОИЗВ(ЕЧИСЛО(НАЙТИ(«андрей»;A1:A10))*(B$1:B$10​ >17​

​есть выгрузка заявок​

office-guru.ru>

Функция РАНГ

Возвращает позицию элемента в списке по его значению, относительно значений других элементов. Результатом функции будет не индекс (фактическое расположение) элемента, а число, указывающее, какую позицию занимал бы элемент, если список был отсортирован либо по возрастанию либо по убыванию.По сути, функция РАНГ выполняет обратное действие функциям НАИБОЛЬШИЙ и НАИМЕНЬШИЙ, т.к. первая находит ранг по значению, а последние находят значение по рангу.Текстовые и логические значения игнорируются.

Синтаксис: =РАНГ(число; ссылка; ), где

  • число – обязательный аргумент. Числовое значение элемента, позицию которого необходимо найти.
  • ссылка – обязательный аргумент, являющийся ссылкой на диапазон со списком элементов, содержащих числовые значения.
  • порядок – необязательный аргумент. Логическое значение, отвечающее за тип сортировки:
    • ЛОЖЬ – значение по умолчанию. Функция проверяет значения по убыванию.
    • ИСТИНА – функция проверяет значения по возрастанию.

Если в списке отсутствует элемент с указанным значением, то функцией возвращается ошибка #Н/Д.Если два элемента имеют одинаковое значение, то возвращается ранг первого обнаруженного.Функция РАНГ присутствует в версиях Excel, начиная с 2010, только для совместимости с более ранними версиями. Вместо нее внедрены новые функции, обладающие тем же синтаксисом:

  • РАНГ.РВ – полная идентичность функции РАНГ. Добавленное окончание «.РВ», сообщает о том, что, в случае обнаружения элементов с равными значениями, возвращается высший ранг, т.е. самого первого обнаруженного;
  • РАНГ.СР – окончание «.СР», сообщает о том, что, в случае обнаружения элементов с равными значениями, возвращается их средний ранг.

Пример использования:

В данном случае используется возврат ранга при проверке диапазона значений по возрастанию.

На следующем изображении отображено использование функции с проверкой значений по убыванию. Так как в диапазоне имеется 2 ячейки со значением 2, то возвращается ранг первой обнаруженной в указанном порядке.

Нулевые строки.

Также имейте в виду, что СЧЕТЕСЛИ и СЧИТАТЬПУСТОТЫ считают ячейки с пустыми строками, которые только на первый взгляд выглядят пустыми.

Что такое эти пустые строки? Они также часто возникают при импорте данных из других программ (например, 1С). Внешне в них ничего нет, но на самом деле это не так. Если попробовать найти такие “пустышки” (F5 -Выделить – Пустые ячейки) – они не определяются. Но фильтр данных при этом их видит как пустые и фильтрует как пустые.

Дело в том, что существует такое понятие, как «строка нулевой длины» (или «нулевая строка»). Нулевая строка возникает, когда программе нужно вставить какое-то значение, а вставить нечего.

Проблемы начинаются тогда, когда вы пытаетесь с ней произвести какие-то математические вычисления (вычитание, деление, умножение и т.д.). Получите сообщение об ошибке #ЗНАЧ!. При этом функции СУММ и СЧЕТ их игнорируют, как будто там находится текст. А внешне там его нет.

И самое интересное – если указать на нее мышкой и нажать Delete (или вкладка Главная – Редактирование – Очистить содержимое) – то она становится действительно пустой, и с ней начинают работать формулы и другие функции Excel без всяких ошибок.

Если вы не хотите рассматривать их как пустые, используйте для подсчета реально пустых клеток следующее выражение:

Откуда могут появиться нулевые строки в ячейках? Здесь может быть несколько вариантов:

  1. Он есть там изначально, потому что именно так настроена выгрузка и создание файлов в сторонней программе (вроде 1С). В некоторых случаях такие выгрузки настроены таким образом, что как таковых пустых ячеек нет – они просто заполняются строкой нулевой длины.
  2. Была создана формула, результатом которой стал текст нулевой длины. Самый простой случай:

=ЕСЛИ(Е1=1;10;””)

В итоге, если в Е1 записано что угодно, отличное от 1, программа вернет строку нулевой длины. И если впоследствии формулу заменять значением (Специальная вставка – Значения), то получим нашу псевдо-пустую позицию.

Если вы проверяете какие-то условия при помощи функции ЕСЛИ и в дальнейшем планируете производить с результатами математические действия, то лучше вместо “” ставьте 0. Тогда проблем не будет. Нули всегда можно заменить или скрыть: Файл -Параметры -Дополнительно – Показывать нули в позициях, которые содержат нулевые значения.

Как посчитать количество ответов «Да» или «Нет» в Excel?

Например, у вас есть рабочий лист с «Да», «Нет» или другими ответами, и вы хотите посчитать процент этих ответов один за другим. Прежде чем подсчитывать процент ответов, вам необходимо знать общее количество ячеек «Да», «Нет» или других ответов по отдельности. В этой статье мы покажем вам, как подсчитать количество ячеек «Да» или «Нет» в Excel.

Подсчитайте число «Да» или «Нет» с помощью функции CountIf

Например, у вас есть ответы в диапазоне ячеек «B15: B21», с помощью формулы функции CountIf вы можете подсчитать количество ответов «Да» или «Нет» следующим образом.

Подсчитайте число «Да»

1. Выберите пустую ячейку, скопируйте и вставьте формулу. = СЧЁТЕСЛИ (B15: B21; «Да») в панель формул и нажмите клавишу Enter. Затем вы можете увидеть отображение результатов в выбранной ячейке. Смотрите скриншот:

Подсчитайте число «Нет»

1. Выберите пустую ячейку, скопируйте и вставьте формулу. = СЧЁТЕСЛИ (B15: B21; «Нет») в панель формул, а затем нажмите клавишу ВВОД.

Посчитайте другой ответ

Например, если есть ответ «нейтральность”Смешайте между Да и Нет, вы также можете подсчитать это с помощью функции CountIf.

1. Выберите пустую ячейку, скопируйте и вставьте формулу. =COUNTA(B15:B21)-COUNTIF(B15:B21,»Yes»)-COUNTIF(B15:B21,»No»)-COUNTIF(B15:B21,»=»»») в панель формул, затем нажмите клавишу Enter. Вы получите количество других ответов, кроме «Да» и «Нет», см. Снимок экрана:

Внимание: После копирования и вставки приведенных выше формул вам необходимо изменить диапазон ячеек в соответствии с вашим листом. YВы можете быстро подсчитать и выбрать ячейки с помощью «Да», «Нет» или других ответов, как показано ниже

YВы можете быстро подсчитать и выбрать ячейки с помощью «Да», «Нет» или других ответов, как показано ниже.

Перед применением Kutools for Excel, Пожалуйста, сначала скачайте и установите.

1. Щелкните Kutools > Выберите > Выбрать определенные ячейки.

2. в Выбрать определенные ячейки диалоговом окне выберите диапазон ячеек в Выберите ячейки в этом диапазоне раздел, выбрать Ячейка в разделе Тип выделения укажите Равно и Да (или Нет и другие) в Конкретный тип раздел и, наконец, щелкните Ok кнопка. Смотрите скриншот ниже.

3. Затем вы увидите, что общее количество ячеек Да отображается в Выбрать определенные ячейки диалоговое окно, а затем щелкните значок OK кнопку.

После нажатия OK Кнопка, все ячейки с Да в выбранном диапазоне ячеек выбираются автоматически.

Вы можете повторить вышеуказанные шаги, чтобы подсчитать ячейки с ответом Нет или другим ответом.

  Если вы хотите получить 30-дневную бесплатную пробную версию этой утилиты, пожалуйста, нажмите, чтобы загрузить это, а затем перейдите к применению операции в соответствии с указанными выше шагами.

Функция СЧЕТ (COUNT) в Excel

​ В более ранних​​ на 2 (​ так.​04.05.2011​ символу; звездочка —​ шрифта. Вот пример​ функция СЧЁТЕСЛИ не​ больше 55 в​СЧЁТЕСЛИ(диапазон;критерий)​ под ней пустой​ проверку этого выражения​​ проработавших более 8​​ указывается ссылка на​

Синтаксис функции СЧЕТ

​ подсчета – «>100».​

​ значение Пустой текст​

​29546​ помочь узнать, сколько​ версиях Excel (например,​ например, на 2​Указали диапазон столбца В.​5​ любой последовательности символов.​

​ подсчета количества ячеек​​ учитывает регистр символов​ ячейках В2–В5. Результат —​Имя аргумента​ ячейкой.​ для каждого значения​

​ часов, используем формулу:​ диапазон ячеек с​ Результат:​ («»), но не​4​ раз встречается определенный​ Excel 2003 года),​ часа). А ячейки​ «Критерий» — поставили​05.05.2011​ Если нужно найти​

Какие значения считаются числовыми

​ определенного цвета с​ в текстовых строках.​ 2.​Описание​База данных в Excel​ в столбце D:D,​Описание аргументов:​ условиями, функция возвращает​Если условие подсчета внести​ пустые ячейки (см.​

  • ​Продажи​ текст или число​ функция СЧЕТ обрабатывала​
  • ​ с числом «7»​ «>300» — это​6​ сам вопросительный знак​ использованием VBA.​
  • ​Критерий​=СЧЁТЕСЛИ(B2:B5;»<>»&B4)​диапазон​ является списком связанных​ соответствующего установленным критериям​A10:B18 – диапазон ячеек,​ массив. Для ввода​ в отдельную ячейку,​ файл примера).​31634​ в диапазоне ячеек.​

​ лишь 30 аргументов.​ умножить на 6​ значит, посчитать все​06.05.2011​ или звездочку, поставьте​

Полезная информация

  • ​Функция​не чувствителен к​Количество ячеек со значением,​
  • ​    (обязательный)​ данных, содержащий поля​ (страна – Украина,​ в котором находится​
  • ​ формулы нужно выделить​ можно в качестве​Если не требуется подсчитывать​3​

Примеры использования функции СЧЕТ в Excel

  1. ​ Например, с помощью​В Microsoft Excel аргументы​ (на 6 часов).​ ячейки в столбце​Формула​ перед ними знак​СЧЁТЕСЛИМН​
  2. ​ регистру. Например, строкам​ не равным 75,​Группа ячеек, для которых​ (столбцы) и записи​ фрукты – яблоки,​ исходная таблица (база​ такое количество ячеек,​ критерия использовать ссылку:​
  3. ​ логические значения, текстовые​ИТ​ функции СЧЁТЕСЛИ можно​ функции СЧЕТ могут​В ячейке F1​ В, где цифры​Описание​

​ тильды (​применяет критерии к​​ «яблоки» и «ЯБЛОКИ»​

​ в ячейках В2–В5.​

office-guru.ru>

Где используется и как работает функция СЧЁТ?

Часто, для анализа табличных данных не нужно производить никаких математических операций с числами. Достаточно уточнить количество показателей. Именно для такого случая пригодится эта простая функция СЧЁТ.

Аргументом функции может быть:

  • любые значения, скопированные и поставленные на место аргумента;
  • одна ячейка или целая область таблицы;
  • формулы и функции.

Синтаксис функции выглядит следующим образом:

=СЧЁТ(аргумент1; аргумент2; …)

Все версии Excel, начиная с 2007, могут учитывать до 255 аргументов при расчёте результата этой формулы. Обязательным является только первый из них. При этом есть разница в том, как учитывается значение, если оно хранится в ячейке или введено в числе аргументов.

  1. Числа, даты и время всегда учитываются функцией СЧЁТ.
  2. Текст и ошибки никогда не учитываются.
  3. Логические значения и текстовое представление числа не учитывается, если оно хранится в ячейке. Если эти же элементы ввести в формулу в качестве аргумента, они будут учтены.

Для понимания этой особенности нужно рассмотреть наглядно на конкретных примерах.

Статистический анализ посещаемости с помощью функции СЧЁТЕСЛИ в Excel

Пример 3. В таблице Excel хранятся данные о просмотрах страниц сайта за день пользователями. Определить число пользователей сайта за день, а также сколько раз за день на сайт заходили пользователи с логинами default и user_1.

Вид исходной таблицы:

Поскольку каждый пользователь имеет свой уникальный идентификатор в базе данных (Id), выполним расчет числа пользователей сайта за день по следующей формуле массива и для ее вычислений нажмем комбинацию клавиш Ctrl+Shift+Enter:

Выражение 1/СЧЁТЕСЛИ(A3:A20;A3:A20) возвращает массив дробных чисел 1/количество_вхождений, например, для пользователя с ником sam это значение равно 0,25 (4 вхождения). Общая сумма таких значений, вычисляемая функцией СУММ, соответствует количеству уникальных вхождений, то есть, числу пользователей на сайте. Полученное значение:

Для определения количества просмотренных страниц пользователями default и user_1 запишем формулу:

В результате расчета получим:

Способ 1: счетчик на строке состояния

Самый простой способ подсчитать ячейки, содержащие данные – это воспользоваться информацией со счетчика, который размещен в правой части строки состояния слева от кнопок переключения режимов просмотра в Excel. Пока на листе выделен диапазон, в котором все элементы пустые или лишь один содержит какое-то значение, данный индикатор скрыт. Счетчик автоматически появляется тогда, когда выделено две или более не пустых ячеек, и сразу показывает их число после слова «Количество».

Но, хотя по умолчанию этот счетчик включен, и только ждет того, когда пользователь выделит определенные элементы, в некоторых случаях он может быть отключен вручную. Тогда актуальным становится вопрос о его включении. Для этого нужно кликнуть правой кнопкой мыши по строке состояния и в открывшемся списке установить галочку напротив пункта «Количество». После этого счетчик опять будет отображаться.

Способ 2: функция СЧЁТЗ

Подсчитать количество заполненных ячеек можно при помощи функции СЧЁТЗ. Она отличается от предыдущего способа тем, что позволяет зафиксировать подсчет определенного диапазона в отдельной ячейке. То есть, для просмотра информации по нему область не нужно будет постоянно выделять.

  1. Выделяем область, в которую будет выводиться результат подсчета. Кликаем по значку «Вставить функцию».

Открывается окно Мастера функций. Ищем в представленном списке элемент «СЧЁТЗ». После того, как это наименование выделено, жмем на кнопку «OK».

Запускается окно аргументов. Аргументами этой функции являются ссылки на ячейки. Ссылку на диапазон можно прописать вручную, но лучше установить курсор в поле «Значение1», куда нужно ввести данные, и выделить соответствующую область на листе. Если нужно произвести подсчет заполненных ячеек в нескольких удаленных друг от друга диапазонах, то координаты второго, третьего и последующего диапазона нужно вводить в поля под названием «Значение2», «Значение3» и т.д. Когда все данные введены. Жмем на кнопку «OK».

Данную функцию также можно ввести вручную в ячейку или строку формул, придерживаясь следующего синтаксиса:

После того, как формула введена, программа в заранее выделенной области показывает результат подсчета заполненных ячеек указанного диапазона.

Способ 3: функция СЧЁТ

Кроме того, для подсчета заполненных ячеек в Экселе существует ещё функция счет. В отличие от предыдущей формулы, она считает только ячейки заполненные числовыми данными.

  1. Как и в предыдущем случае, выделяем ячейку, куда будут выводиться данные и таким же способом запускаем Мастер функций. В нём выбираем оператора с наименованием «СЧЁТ». Жмем на кнопку «OK».

Запускается окно аргументов. Аргументы те же самые, что и при использовании предыдущего способа. В их роли выступают ссылки на ячейки. Вставляем координаты диапазонов на листе, в которых нужно подсчитать количество заполненных ячеек числовыми данными. Жмем кнопку «OK».

Для ручного введения формулы придерживаемся следующего синтаксиса:

После этого в области, в которой находится формула, отобразится количество ячеек, заполненных числовыми данными.

Функция СЧЕТЕСЛИ в Excel и примеры ее использования

​ всегда учитываются функцией​ в Excel выборочно»​В некоторых примерах в​Подсчитывает количество строк, содержащих​ нажмите клавишу F2,​ ниже.​ (*). Вопросительный знак​

Синтаксис и особенности функции

​Количество ячеек со значением,​

  • ​    (обязательный)​ требуется передать название​ синтаксис:​
  • ​ число работников в​ автоматизированной и эффективной​Для расчета количества значений,​

​Сначала рассмотрим аргументы функции:​1​8 000​ СЧЕТ как числовые.​ тут.​ формулах стоит знак​

​ числа меньше 5​ а затем — клавишу​Диапазон_условия1.​ соответствует одному любому​ большим или равным​Число, выражение, ссылка на​ столбца таблицы или​=БСЧЁТ(база_данных; поле; условия)​ ячейке C2 –​

​ работы с данными.​ оканчивающихся на «и»,​

  • ​Диапазон – группа значений​Продажи​Шашков​Пустые ячейки, ошибки и​Еще один пример​
  • ​ «звездочка». Это подстановочный​ в ячейках A2–A7​ ВВОД. При необходимости​
  • ​    Обязательный аргумент. Первый диапазон,​ символу, а звездочка —​
  • ​ 32 и меньшим​ ячейку или текстовая​ списка, под которым​=БСЧЁТА(база_данных; поле; условия)​ соответственно.​ Поэтому продвинутому пользователю​ в которых содержится​ для анализа и​43068​20 000​
  • ​ текст, который не​ использования функции «СЧЕТЕСЛИ»​ знак. Ддя чего​ и даты раньше​ измените ширину столбцов,​

Функция СЧЕТЕСЛИ в Excel: примеры

​ любой последовательности знаков.​ или равным 85,​ строка, которая определяет,​ расположены ячейки для​

​Описание аргументов функций:​​

​ настоятельно рекомендуется внимательно​ любое число знаков:​ подсчета (обязательный).​2​Грачев​ может быть преобразован​

​ смотрите в статье​ эти подстановочные знаки,​ 03.05.2011 в ячейках​ чтобы видеть все​

​ проверить соответствие заданному​ Если требуется найти​ в ячейках В2–В5.​ какие ячейки нужно​

​ выполнения поиска.​

​база_данных – обязательный для​Пример 2. Определить количество​ изучить все приведенные​

​ =СЧЁТЕСЛИ(A1:A11;»*и»). Получаем:​Критерий – условие, по​

​Управление персоналом​5 000​ в числа, функция​ «Как объединить данные​ какие ещё есть​

​ B2–B7.​ данные.​

​ условию.​ непосредственно вопросительный знак​ Результат — 3.​

​ подсчитать.​Аргумент поле обеих функций​ заполнения аргумент, принимающий​ работников, фамилия которых​ выше примеры.​

​Формула посчитала «кровати» и​ которому нужно подсчитать​

​45382​Нагайчук​ СЧЕТ игнорирует.​ теста в ячейках​ знаки, где их​2​Продавец​Условие1.​ (или звездочку), необходимо​=СЧЁТЕСЛИ(A2:A5;»*»)​

  1. ​Например, критерий может быть​ может быть не​ данные в виде​ начинается на «Соло».​Посчитаем количество реализованных товаров​ «банкетки».​ ячейки (обязательный).​2​
  2. ​22 500​Логические значения, а также​ в Excel» здесь.​ еще можно использовать,​=СЧЕТЕСЛИМН(A2:A7; «​Превышена квота Q1​    Обязательный аргумент. Условие в​ поставить перед ним​
  3. ​Количество ячеек, содержащих любой​ выражен как 32,​ указан. В этом​ ссылки на диапазон​ Продемонстрировать различие в​ по группам.​
  4. ​Используем в функции СЧЕТЕСЛИ​В диапазоне ячеек могут​Финансы​Формула​ текстовые представления чисел​В Excel много​ читайте в статье​Такое же описание, что​Превышена квота Q2​ форме числа, выражения,​
  5. ​ знак тильды (~).​ текст, в ячейках​ «>32», В4, «яблоки»​ случае поиск будет​ ячеек, в которых​ использовании функции БСЧЁТ​Сначала отсортируем таблицу так,​ условие поиска «не​ находиться текстовые, числовые​47971​Описание​ (например, число, заключенное​ разных способов провести​ «Подстановочные знаки в​

​ и для предыдущего​Превышена квота Q3​ ссылки на ячейку​Например, =СЧЁТЕСЛИ(A2:A5;»яблок?») возвращает все​ А2–А5. Подстановочный знак​ или «32».​ произведен во всех​ находится база данных​ и БСЧЁТА для​

ПРОМЕЖУТОЧНЫЕ.ИТОГИ и СЧЕТЕСЛИ

​ чтобы одинаковые значения​ равно».​

  1. ​ значения, даты, массивы,​1​Результат​
  2. ​ в кавычки), учитываются​ анализ данных в​ Excel».​ примера, но вместо​Ильина​ или текста, которые​ вхождения слова «яблок»​ «*» обозначает любое​В функции СЧЁТЕСЛИ используется​ полях базы данных​

​ либо список;​ подсчета количества ячеек,​

​ оказались рядом.​Формула: =СЧЁТЕСЛИ(A1:A11;»<>»&»стулья»). Оператор «<>»​ ссылки на числа.​ИТ​=СЧЁТЕСЛИ(A2:A7,»Грачев»)​ функцией СЧЕТ по-разному.​

exceltable.com>

СЧЕТЧИК

Очень полезно для проверок, функций Говорить пусто служит для подсчета количества пустых ячеек в заданном диапазоне. Его синтаксис имеет только один аргумент, логически необходимый:

= COUNTDOWN (интервал)

Давайте покажем пример, чтобы увидеть, как работает эта функция:

Мы вводим таблицу с десятью самыми густонаселенными странами. Чтобы проверить, была ли ошибка, заполняющая данные, давайте использовать Говорить пусто.

Чтобы создать формулу функции, мы должны правильно ввести требуемый интервал. Поскольку мы хотим сначала проверить ячейки столбца «позиция», давайте определим диапазон как B4: B13.

По завершении функции мы видим, что результатом был «0». То есть в указанном диапазоне нет пустых ячеек. Повторяя процедуру для других столбцов, мы будем иметь следующий сценарий:

Мы можем видеть красным, что функция возвратила два пустых пространства в столбце «Население». Проведя конференцию на столе, мы заметили, что число жителей Индонезии и Нигерии не было напечатано.

Этот инструмент полезен для обнаружения возможных ошибок на более длинных интервалах

Важно знать, что ячейки с нулевыми значениями не считаются пустыми

Гость форума
От: admin

Эта тема закрыта для публикации ответов.